NCP automatic Backup not working


I hope I’m in the right place. I use NextcloudPi to manage my NextCloud instance. I have now integrated another hard disk into the system which is intended exclusively for backups. The backups should contain the usual system backups (configurations, database etc.) and additionally back up my data.

If I do this manually in the ControlPanel under nc-backup, then the backup is saved as a tar file at the location I specify. Since I do not want to start the backup manually every day, I have activated nc-backup-auto. Unfortunately, it doesn’t seem to be working. So far no backup has been created.

I tried to find the error by looking at the script that performs the automatic backup. I think this is done by an entry in the cron. But neither crontab -e (pi, root) nor /etc/crontab or /etc/cron.*/ indicate an automatic backup. So I think that I am either looking for it in the wrong place or that there is an error in the ControlPanel. I also find it strange that I cannot select a time for the backup via the panel. Backing up data to a RaspberryPi is something I would like to do at a time that would not hinder me. At night, for example.

Can someone help me with this topic?


OK, i found the script ncp-backup-auto in /usr/local/bin/ I will create now a cronjob. Hopefully i did not damage anything :wink:



In my case, after enabling nc-backup-auto I get the following file in cron

cat /etc/cron.d/ncp-backup-auto
0  3  */7  *  *  root  /usr/local/bin/ncp-backup-auto

You should be seeing the same

1 Like

No in my case there was no such entry in the cron after enable it. But i have do an identical entry in the cron by hand. This is working for me also.


Hi, is have the same problem as described above.
manuall backup (“nc-backup”) -> i.O.
automatic backup (“nc-backup-auto”) -> n.i.O.

the Path for the Backupdata is the same in both Panals.

the file “ncp-backup-auto” has been created and it contains the same data as nachoparker wrote.
So far no auto-backup has been created.

Automount USB drives is activated

check /var/log/mail, maybe you need to reset your root pwd

1 Like

there are different files (mail.err,, mail.log, mail.warn),
I couldn’t find something usefull in them, but if it helps i can post their content.

anyway, i changed the password for root, and activated automatic backup again.
there is still no auto-backup

edit: last night it did the auto-backup :slight_smile: you must have been right with the root pwd. Thank you!