NC29 - Cant get the share link URL

NC 29 on Debian with Apache2 web server

Im having the dreaded issue that I cant create a link to share the normal way.
Basically I can create the shared folder. However when I click to copy the URL for it, it will say that it cant copy it and that I should copy it manually.

How ? Theres nowhere that I can get that link from. EXCEPT by creating a QR code and then scanning it with my phone. That actually gives me that URL. But then I have to transfer it from my phone to where I need to use it. Quite the hassle really.

Ive read that it should work by using https but sadly that isnt an option as Ill consistently have issues with the lets-encrypt.
If at least it would let you SEE the url when you create it then I could copy that. But it doesnt. Not even on the qr code does it show the url so that I could copy it.

What does it mean by saying to copy the url manually ? From where ?

If you hover over the copy link to clipboard, it also shows the link in the status bar of the browser. In my case (FF), I can do a right click and use copy link.
Why it does not copy in the first place, I’d take a look in the browser extensions that might be blocking something, perhaps try a different browser/computer if that is the case there as well.

I don’t know your setup and why it is difficult with letsencrypt. However, I’d try to avoid running such services without a secure connection. Locally running tests or something like that might be an exception.

No real idea. But maybe you can set in config/config.php:

'overwrite.cli.url' => 'http://cloud.server.tld',
'overwriteprotocol' => 'http',

It doesnt show any link at the bottom of FF which im also using. Ive tried it on the local computer as well as from outsite the network. Same thing. Even across browsers too.

It doesnt show any link. It has a popup when i hover the button saying “Copy public link of “Del link” to clipboard” But when i click it. It does nothing. Then I can hover the button again and itll tell me that it cant copy the link and that I need to copy it manually. Which makes no sense as theres nowhere that this link shows up that I can copy from.

My issue with the lets-encrypt is that I its a subdomain much like
I can access my domain when I add the specific port number im using that routes the trafic on that port into my server.

And your apache config is similar to the documentation?

And you access directly without going through reverse proxies/other?

Ok, that looks a bit more difficult, on your own domain name, you could do authentication via DNS.
For Nextcloud, I’d try to use the standard https port because in some environments (free wifi, company networks etc.) non-standard ports are likely to be blocked.

I have NC 28/stable and tried 28/edge, but across 3 browsers the right click is disabled. This happened to me after the 12 june.