NC28 MindMap KM files not working

NC 28.0.0

mindmap APP (mindmap 0.0.3 from fedwiiix <---- outdated / abandoned as @tflidd mentioned

Mind Map 0.0.30 from Jingtao Yan

see … github issue not working in NC.28.0.0

(Issues · ACTom/files_mindmap · GitHub)

not working
km files not opend … just downloaded

removed app
and reinstalled it

Any ideas … or work arounds …

br NP

The project looks abandonned:
https://github.com/fedwiiix/mindmap_app

Last version for NC20. It could take some effort to make it compatible with a current NC version.

I found a different mind map app in the app store: https://apps.nextcloud.com/apps/files_mindmap

yeap
mixed it up
but still not working … :wink:

see github issue

1 Like

Let’s just keep a link here for others and hope for a quick fix:

2 Likes

just for the records …
as of today still not working …
and there is no movement in resolving it …

There is a pull request with the modifications, you can manually use this version and test. Not sure about the repo owner, in thoery someone could fork the app. Or ask to move the repo to Nextcloud, then several people could more easily maintain the package…

2 Likes

i think i need some extra education how to do that …

I found that they even put this in the documentation:
https://docs.nextcloud.com/server/latest/admin_manual/issues/applying_patch.html

Yes, that is about applying a patch, which is peanuts but in this case, one have to pull and compile the app. So it is a little more nerdy :wink:

ernolf

1 Like

I built it for Nextcloud 28, you can download it here:

Read about the limitations here: Adapt to NC 28 by artonge · Pull Request #190 · ACTom/files_mindmap · GitHub


ernolf

3 Likes

YEHAAAAAAA !!!

Thank YOU !

THX !!!

OK, I downloaded yours, rm -rf’ed my files_mindmap in my NC/apps/ directory, tar xvfz’ed yours, checked the permissions, tried to open a .km… and it’s still downloading.
I tried with a km which isn’t shared between users, same.

What am I doing wrong?
(my own official git cloned with the pending PR was maybe OK after all, if I’m not able to use yours…). Any help appreciated

I disabled the pluging and re-enabled it, with no more success

Regards

You did only report that it doesn’t work but you forgot to provide the rest of the information:

  • Nextcloud Version
  • webserver
  • php-SAPI
  • host-OS
  • browser

Did you try it from within an incognito tab?

Did you chown the files?

etc…

ernolf

Hi,
Sorry I had no time to try and fix it.

I tried again (redownloaded your package) and opened a km file from a “private” tab. Same.

I’m using NC 28.0.2 on a standard Debian 12 (php 8.2.7) + nginx 1.22.1 + php-fpm
Firefox latest update (right now 122.0.1). I tried in Edge, it just downloads the file, too.

php-sapi??

Of course I chown’ed and chmod’ed everything according to my nginx pool ownership. 755 on directories + 644 on files. I deleted the existing files_mindmap before and put yours.

I tried with a shared km file and with a non-shared one.
I can’t find the menu to create a mindmap like before when I just click on the + button to create a file.
I deactivated/reactived the plugin.

Any idea? some debug information to activate somewhere?

Regards