NC28 Admin Apps page is frozen / No scrolling possible

Since upgrading to NC28.0.3 from NC27.1.7 I can’t navigate in the followings Apps admin view mode : Your apps, Active apps, Disable apps, Bundle …
The apps are visible but it is impossible to scroll or select any of it.
The only way to install or update is to navigate in the categorised menu.

The server is self hosted on Ubuntu 22.04.4 LTS with NGINX, PHP 8.2
Config file:

$CONFIG = array (
  'instanceid' => ‘my instance’,
  'passwordsalt' => ‘mysalt’,
  'secret' => ‘mysecret’,
  'trusted_domains' => 
  array (
    0 => 'cloud.mydomain’,
  'datadirectory' => '/opt/nextcloud-data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://cloud.mydomain’,
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nxcloud’,
  'dbpassword' => ‘mypsw’,
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => 'localhost',
    'port' => 6379,
  'app_install_overwrite' => 
  array (
    0 => 'bruteforcesettings',
    1 => 'groupfolders',
    2 => 'spreed',
    3 => 'richdocumentscode',
  'enable_previews' => true,
  'preview_max_x' => 2048,
  'preview_max_y' => 2048,
  'loglevel' => 3,
  'logtimezone' => 'Europe/Paris',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'log_rotate_size' => 104857600,
  'maintenance' => false,
  'default_phone_region' => 'FR',
  'theme' => '',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => ‘me’,
  'mail_domain' => ‘domain’,
  'mail_smtphost' => ’smtp’,
  'mail_smtpport' => '587',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtpname' => ‘email’,
  'mail_smtppassword' => ‘psw’,
  'filelocking.enabled' => 'true',
  'trashbin_retention_obligation' => 'auto, 60',
  'updater.secret' => ’secret’,
  'maintenance_window_start' => 1,
  'memories.exiftool' => '/var/www/nextcloud/apps/memories/bin-ext/exiftool-amd64-glibc',
  'memories.vod.path' => '/var/www/nextcloud/apps/memories/bin-ext/go-vod-amd64',
  'memories.vod.ffmpeg' => '/usr/bin/ffmpeg',
  'memories.vod.ffprobe' => '/usr/bin/ffprobe',
  'enabledPreviewProviders' => 
  array (
    0 => 'OC\\Preview\\Image',
    1 => 'OC\\Preview\\HEIC',
    2 => 'OC\\Preview\\TIFF',
    3 => 'OC\\Preview\\Movie',

I usually find solution to all bugs through forums or documentation, but this time I am short of ideas.

All apps were updated?

They are all compatible and don’t create the error?

Please check the logfiles, if you can find any hints. If it is linked to an app, it should show in the logs.

For the views, it can also be worth checking the browser console if a resource failed to load, or if some code was blocked to be loaded (add blocker, AV software).

I am also having this problem. Cannot scroll through or select apps in the app admin page in Nextcloud 28. And the only way to update an app is to use the “update all” button at the top.

A bug like this showed up several versions ago, maybe with 23 or 24. Some very nice folks on this forum traced it to an error in the PlatformRepository.php file at … /public_html/lib/private/App/PlatformRepository.php

Those folks provided a corrected version of the file that we could upload as a replacement and it worked like a charm.

Unfortunately, I just tried to re-upload that old correction to see if it would fix it in Nextcloud 28, but to no avail.

But I wanted to mention it, as a lead, in case anyone is better at spotting (and fixing) malfunctioning files like that.


All apps are updated, and all compatible.
I cheked the log but noting helps me.

I tested with Mozilla instead of Safari : No problems with Mozilla, the app admin page is full operational even sliding and selecting the different apps.

I tried to check with the consol of Safari but I found no hints (I’m not expert in browser).

It seams to me that it comes from the browser config and the java script that drives the UI mouse reaction.

Ok, luckily Safari is among the supported browsers as well (The Nextcloud Web interface — Nextcloud latest User Manual latest documentation), so you can try to file a bug report at
If others can easily reproduce this issue on Safari, it should be easy for the developers to analyze the problem. @m100 are you using Safari as well?

I am indeed. Also tested on Duck Duck Go’s new browser. But have not tried any others.

Thanks for the link for the bug report.

Thanks for reporting, here is the issue on github:

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.