NC25 to 26 - not offered, upgrade php (7.4)?

I’m running 25.0.8 on php7.4 on Ubuntu 22.04, and no matter what channel I use, it does not offer me NC26, likely because of the php version. I’ve tried installing 8.0 and 8.1 (they both are listed in “update-alternatives --config php”

There are 9 choices for the alternative php (providing /usr/bin/php).

Selection Path Priority Status

0 /usr/bin/php.default 100 auto mode
1 /usr/bin/php.default 100 manual mode
2 /usr/bin/php5.6 56 manual mode
3 /usr/bin/php7.0 70 manual mode
4 /usr/bin/php7.1 71 manual mode
5 /usr/bin/php7.2 72 manual mode
6 /usr/bin/php7.4 74 manual mode

  • 7 /usr/bin/php8.0 80 manual mode
    8 /usr/bin/php8.1 81 manual mode
    9 /usr/bin/php8.2 82 manual mode

but if I try to enable 8.0 or 8.1, restart apache, I get this when I try to open the web frontend.

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

I’ve checked that I have these pachages installed. What am I missing? I really need to get past this before they obsolete NC25…

sudo apt-get install php8.0-zip libapache2-mod-php php8.0-gd php8.0-json php8.0-mysql php8.0-curl php8.0-mbstring php8.0-intl php8.0-imagick php8.0-xml php8.0-zip php8.0-mysql php8.0-bcmath php8.0-gmp php8.0-zip -y

When you enable either 8.0 or 8.1 and get that Internal Server Error, the details will be in your nextcloud.log (located in your data directory). Or, if things are really bad and Nextcloud isn’t even entering the picture, in your Apache logs. Those details in the logs will tell you what is missing.

I really need to get past this before they obsolete NC25…

Still have until October fortunately. We - those that help out here at the forum - can get this worked out before that I’m fairly confident.

You have a couple duplicates in your php8.0 modules list, but that’s fine. You appear to the bare essentials, but I don’t know what configuration you’re using (e.g. redis?) nor optional/other apps you’re using so there could be others needed. Either way, let’s check the logs.

Thanks, I had a couple of errors. acpu was installed but not enabled, and there were some missing indices. Also had to change the php8.x-fpm.ini memory_limit to 512 or greater (and RESTART the service!!), but then got onto NC26. Thanks for your insight.