Nc19 - Internet explorer login not working

nc19 - Internet explorer login not working

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version:
Operating system and version: Ubuntu 18.04.4 LTS
Apache version: 2.4.29
PHP version: 7.2.24
Nextcloud app involved: LDAP integration, nextcloud outlook plug-in

The issue you are facing: Nextcloud web login page is not working anymore with Internet Explorer, showing lots of errors related to some variables not declared, I suppose that is related to incompatiblity with the new nextcloud version.

Here below the Internet Explorer console output:

DOM7011: The code on this page disabled back and forward caching. For more information, see:
HTML1300: Navigation occurred.
SCRIPT1014: Invalid character
main.js (791,21360)
SCRIPT5009: 'OC' is undefined
merged-template-prepend.js (26,1)
SCRIPT5009: 'OCA' is undefined
search.js (196,2)
SCRIPT5009: 'OC' is undefined
it.js (1,1)
SCRIPT5009: 'OC' is undefined
it.js (1,1)
SCRIPT5009: 'OC' is undefined
main.js (23,1)
SCRIPT5009: 'OCA' is undefined
previewplugin.js (15,2)
SCRIPT5009: 'OC' is undefined
main.js (22,1)
SCRIPT5009: 'OCA' is undefined
searchprovider.js (410,2)
SCRIPT5009: 'OC' is undefined
fileinfo.js (11,2)
SCRIPT5009: 'OC' is undefined
client.js (13,2)
SCRIPT5009: 'dav' is undefined
iedavclient.js (12,2)
SCRIPT5009: 'OCA' is undefined
login.js (318,26387)
SCRIPT5009: 'OCA' is undefined
theming (2,2)
SCRIPT5009: 'OCA' is undefined
accessibility (2,2)

This issue is preventing users to log in via internet explorer, that is involved in the process of login for the free outlook plugin, therefore atm for NC19 the nextcloud outlook plugin is working only with already logged-in users , but if they change password there is no chanche to change it in the plug-in.

Is this the first time you’ve seen this error? yes

Steps to replicate it:

  1. Update nextcloud to version 19
  2. Open internet explorer in the nc login page
  3. Open the dev console of internet explorer and look at console window

The output of your Nextcloud log in Admin > Logging:
Due to some document spamming errors in the logs for document server app, the logs are very long, anyway i don’t think it is really needed in this case (no entry is shown for this specific issue)

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'datadirectory' => '/mnt/ncdata',
  'dbtype' => 'pgsql',
  'version' => '',
  'dbname' => 'nextcloud_db',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'installed' => true,
  'instanceid' => 'ocsomvq2d0jh',
  'log_type' => 'file',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'loglevel' => '2',
  'mail_smtpmode' => 'smtp',
  'remember_login_cookie_lifetime' => '1800',
  'log_rotate_size' => '10485760',
  'trashbin_retention_obligation' => 'auto, 180',
  'versions_retention_obligation' => 'auto, 365',
  'simpleSignUpLink.shown' => 'false',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'filelocking.enabled' => true,
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => 0,
    'timeout' => 0.5,
    'dbindex' => 0,
  'logtimezone' => 'Europe/Rome',
  'htaccess.RewriteBase' => '/',
  'enable_previews' => true,
  'preview_libreoffice_path' => '/usr/bin/libreoffice',
  'ldapIgnoreNamingRules' => false,
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'maintenance' => false,
  'mail_from_address' => 'noreply',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => '',
  'mail_smtphost' => 'palspap01.pal.local',
  'mail_smtpport' => '25',
  'app_install_overwrite' => 
  array (
    0 => 'drop_account',
    1 => 'files_trackdownloads',
    2 => 'drawio',
    3 => 'impersonate',
    4 => 'sharepoint',
  'overwrite:cli:url' => '',
  'overwrite.cli.url' => '',
  'theme' => '',

The output of your Apache/nginx/system log in /var/log/____:
I don’t think it’s really needed this

I can confirm this.
Konsole Output in IE (sorry, german locales)

I have freshly installed Nextcloud 19. I tried to access it throught IE 11 but the login form doesn’t show up.


javascript enabled? scriptblocker stopped for the referring site?

JS is enabled. I have a lot of JS error like « OC » is undefined

have you tried a different browser?

I have no problem on other browser

@Executable i moved your thread here as it seems to deal with the same problems… please search the forum for already existing similar problems before posting

@Executable @zerwes @Fin3 if you think that this is a bug… try filing an issue under github and don’t forget to doublecheck if it was already filed and - if no - to post the link here as an answer