NC18 clean installation but ONLYOFFICE doesn't work?

I’ve followed https://docs.nextcloud.com/server/18/admin_manual/installation/source_installation.html and https://docs.nextcloud.com/server/18/admin_manual/installation/example_ubuntu.html to perform a clean installation of NC18 onto Ubuntu 18.04.

According to https://nextcloud.com/blog/the-new-standard-in-on-premises-team-collaboration-nextcloud-hub/, “ONLYOFFICE’s community edition is installed by default on a new Nextcloud installation” but that didn’t seem to be the case.

The ONLYOFFICE connector got installed but the community document server did not. I have now installed that but any attempt to open an Office document within NextCloud produces a pop-up that says “ONLYOFFICE Cannot be reached. Please contact admin”.

There is an ONLYOFFICE settings pane and the Document Editing Service address is set to the same as the NextCloud server.

What did I do wrong? I cannot find much in the way of explicit instructions to get ONLYOFFICE working for NC18, which does suggest it should be very straightforward but something clearly isn’t working properly.

did you install your new server to an arm-machine?

No. It is an Intel server.

umm well… then i dunno.

it would be good tzo get some more infos on your installation. like the template here in that category demanded initially.

Nextcloud version (eg, 12.0.2) : 18.0.1
Operating system and version (eg, Ubuntu 17.04) : Ubuntu 18.04
Apache or nginx version (eg, Apache 2.4.25) : Apache/2.4.29
PHP version (eg, 7.1) : PHP 7.2.24-0ubuntu0.18.04.3

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => '<REDACTED>',
  'passwordsalt' => '<REDACTED>',
  'secret' => '<REDACTED>',
  'trusted_domains' =>
  array (
    0 => '<REDACTED>',
  ),
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '18.0.1.3',
  'overwrite.cli.url' => '<REDACTED>',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => '<REDACTED>',
  'dbpassword' => '<REDACTED>',
  'installed' => true,
  'maintenance' => false,
  'mysql.utf8mb4' => true,
);

There is nothing in the NextCloud server logs.

oh i just re-read your initial posting…
so one more question: after having manually installed OO-community document server did you deactive, remove and reinstall oo-connector? if not… pls do so.

and i guess it would be helpful if you’d make a screenshot of your setting page of oo-connector

I think I did but I’ve just done it again to be sure and it hasn’t helped.

Here is the OO connector settings page:

I’ve got it working now. The server URL was incorrect. The full fix was:

  1. Remove the server URL from the settings and click on Save.
  2. Disable and remove the connector.
  3. Download and enable the connector.

It looks like removing apps from NextCloud does not remove any configuration settings they might have. If it did, removing and reinstalling the connector would have been sufficient.

Out of interest, should the document server have been installed automatically as per the blog post I linked to?

2 Likes

To users who upgrade from v17, there is a guide to activate OnlyOffice

1 Like

Nope, that didnt do it for me unfortunately, did you you reboot inbetween the steps at some point?
Did you remove the document server as well at some point

It has been a while now but I’m pretty certain that the issue I was seeing was only caused by the connector app retaining the wrong URL. No reboot was necessary, nor was it necessary to remove the document server. That said, neither of those two actions would hurt to try.