Nc16 > php7.3 on shared server not working

I have several problems during the update because of my shared server (and allinkl isn’t supporting well like 10 years ago…).

Now I wanted to start “php occ update” and the program says “You are currently running 7.0.32-nmm1.” but I have 7.3. But it’s complicated. allinkl runs anything like Zend Engine.

  1. The phpinfo() shows:
    PHP Version 7.3.6-nmm1
  2. The command
    php -version
    in the shell shows:
    PHP 7.0.32-nmm1 (cli) ( NTS )
    Copyright (c) 1997-2017 The PHP Group
    Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from (unconfigured) v10.3.1, Copyright (c) 2002-2018, by ionCube Ltd.

Is there a possibility to run the update command?
Nextcloud was running good and the updates from 13 to 14 and 14 to 15 worked well.

Thank you very much for your help!


There seem to be two versions of PHP running on your server. PHP-cli with version 7.0 and some other PHP installation with version 7.3.
Can you somehow find out where the 7.3 version is installed to? If you find out, you can run the command with:
/path/to/7.3-php/bin/php occ ...

1 Like

So great. I tried around like with python/python3 and it’s … tadaaaa:


Thanks a lot!

1 Like