NC11: Written comments vanish and comments with @username don't get written

I upgraded to Nextcloud 11 yesterday and just noticed two problems:

  • written comments under files and folders vanish after I closed the Details view (comment area is completely white)
  • comments with @username won’t appear as saved at all (never ending loading symbol; the turning circle)

When I look at the activity tab in the file details, I see that comments have been written, but still comments tab is always empty.

I don’t see any error message in the logs and have no idea what could be wrong here.

Ubuntu 16.4
PHP 7.0.8
MySQL 5.7.16
Apache 2.4.18

Can you please check your logfiles for errors (nextcloud, webserver)? Are these shared folders?


I checked the log files but no related entries there. That’s what made it very difficult for me to find out where to start my search for the root cause. I was thinking that maybe someone else has or had this problem.
Yes, these are shared files/ folders. For testing proposes I commented both files/ folders shared by me and also shared by another user.

You can set the loglevel to debug in the admin-interface.

But these are not on external storage?

Hi @tflidd,

loglevel debug was already activated and I ran some tests now again: there are absolutely no log entries when I comment on a file :worried:

With a lot of testing I found out the following:

  • commenting works in general for “normal” comments (comments without mentions using @<username>)
  • the first mention with @<username> totally breaks the comment section for that file/ folder
    → every “normal” comment that existed before vanishes
    → every new comment won’t appear in the comment section
    → other users receive a notification about the new comment but don’t see any comment, too
    → only chance to fix comment section for this file/ folder is to delete the comment in the database

And as said: no error messages in any log! Not even info messages or something like that.

Here are some screenshots, showing how it looks for the user.

Writing a comment with a mention of another user (the turning circle doesn’t disappear even after half an hour):

The admin user received the notification about the comment but sees nothing:

When I reload the file details and comment section for the user that wrote the comment:

And no, this is the local storage. I don’t have any external storage mounted.

A turning circle can indicate that your browser is waiting a response from the server. Can you check the network console of your browser? Which browser are you using, any plugins? I can’t reproduce this on my NC 11 setup at all.

I used MS Edge on PC, MS Egde on Smartphone and Firefox latest ESR version. I disabled all plugins for testing, but no change. It is so strange anything apart from mentions works fine.

In the network console of Firefox there are no problems. Every request is handled quickly.

I enabled mysql logging and had a look into the queries. What I noticed is, the query against oc_properties requests information for mentions and this query doesn’t return anything:

2016-12-18T17:05:40.288001Z       43 Query    SELECT * FROM `oc_comments` WHERE (`object_type` = 'files') AND (`object_id` = '3') ORDER BY `creation_timestamp` DESC LIMIT 21
2016-12-18T17:05:40.290459Z       43 Query    SELECT `marker_datetime` FROM `oc_comments_read_markers` WHERE (`user_id` = '*****') AND (`object_type` = 'files') AND (`object_id` = '3')
2016-12-18T17:05:40.291534Z       43 Query    SELECT * FROM `oc_properties` WHERE `userid` = '******' AND `propertypath` = 'comments/files/3/28' AND `propertyname` in ('{}mention', '{}mentionType', '{}mentionId', '{}mentionDisplayName')

Running a
SELECT * FROM oc_properties;
I see no entries with .*mention at all and shortening the query to
SELECT * FROMoc_propertiesWHEREuserid= '******' ANDpropertypath= 'comments/files/3/28';
still doesn’t deliver any DB output.

The DB query, that inserts the necessary values into the table oc_properties is totally missing. There is no INSERT statement for oc_properties when I write a mention into the comment.

I can’t help you here. Put all your findings together and submit a bug report.

Just providing what finally helped me, in case somebody stumbles across this thread having the same problem.

For some reason the PDF viewer app caused this problem and my problem was solved by disabling the app. I made some comments with mentions and it worked as expected.
I enabled the PDF viewer app again and mentions still worked.

Unfortunately I always tested the mentions on that PDF file, so probably it would have worked on other files and folders. Nevertheless, while the PDF viewer app creates a preview it interfered somehow with the mentions in the comments. But no longer after the app was disabled.

Thanks for the help in the issue by nickvergessen.

1 Like