NC11 won't accept my admin password?

Hello, I just got done setting up a Nextcloud 11 installation running on Debian 8.6 Jessie and it went fine, Until i got to the point where i am now in the web interface to setup a couple of user accounts and no matter how many times i put in my admin password it keeps asking for it as shown in this image.

It has the same issue if i try and add an addon, However i am able to change the administrator password fine. The /var/www/nextcloud folder and all contents are all owned by the www-data user so that shouldn’t be the issue. Any help would be appreciated. Thanks.

Ähm, just because I sometimes mix that up myself: Did you try to enter your system admin password for linux (or whatever) instance or as it should be the password of your nextcloud user? Sorry for asking that, but as I said I sometimes type my system admin password three times, before I realize that I am trying the wrong :wink: .

I am using the admin password for the nextcloud instance. If i give it something wrong it the gives me “Failed to authenticate, try again” However if i give the right one it fades away then fades back in.

There are a few people with this problem but they haven’t figured out yet what’s actually wrong:

1 Like

Guess i should of looked on github for other people having a similar issue. Thanks tflidd! Guess i just shelve this VM for a couple of days or so and come back to it after a solution has been found.

If you can contribute to this topic, that can be helpful. If you just set it up and don’t have any confidential content, you might even provide a copy of it (or access) to the developers.

Ill see what i can do on that front. I wouldn’t be able to provide access but could a copy of the VM image if it would help.

Any answer to this issue?

I have a fix that worked for me, it’s simple if you are using samba AD and nextcloud. There is a default “admin” user created by nextcloud during the install. Even though you can still login as admin via the web interface, without an identical user “admin” in samba it will not auth, resulting in the above symptom.

To the bug report there have been some fixes which should be in NC 11.0.2. If you stil experience problems, please report it directly on the bugtracker:

I don’t think it’s a bug. I’m running 11.0.2. I think it makes perfect sense now, just wasn’t obvious to me at the time. I was thinking of Samba users as one thing and Admin as another, like on a windows machine local account and a domain account. It was a light bulb turning on realization, followed by a facepalm.

I had the same problem. My client desktop time setting was 1 hour off from the server time.

After setting the correct client time the “authentication required” issue was solved.

Hope that helps!

I’m having this same issue right now on both 12.04 and 12.03. I’ve reinstalled several times. I’ve gone through the raspbian config (on raspberrypi) menu and made sure the time zone was accurate to the server location (my location) but it still doesn’t work. My desktop pc is the same.

Where exactly did you make your changes?