NC upgrade not finished/maintenance mode

Sorry to hear you’re facing problems :slight_frown:

If you’re urgently looking for support to keep your business running, consider checking out our paid support options.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the following as you can (you can cut and paste this into your topic):

Nextcloud version 11.:
System: Qnap TVS 463

The issue you are facing:

After trying to Update Nextcloud to version 12.0.3 the system is not leaving the maintenance mode. Any ideas what to too?

What did you try so far? Disable maintenance mode via occ command? Or in the config/config.php file? Did the upgrade finish?

Hey, no the update did not finished. in the config.php it tells me, that the maintenance is allready off

$CONFIG = array (
  'instanceid' => 'oceg5x3don56',
  'passwordsalt' => 'xxxx',
  'secret' => 'xxxx',
  'trusted_domains' => 
  array (
0 => '',
1 => '',
  'datadirectory' => '/share/CACHEDEV1_DATA/.qpkg/owncloud/owncloud/data',
  'overwrite.cli.url' => '',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'owncloud',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'oc_admin',
  'dbpassword' => 'xxxx',
  'installed' => true,
  'mail_from_address' => 'owncloud.michel.bargon',
  'mail_smtpmode' => 'smtp',
  'mail_domain' => '',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtpsecure' => 'ssl',
  'forcessl' => true,
  'forceSSLforSubdomains' => true,
  'theme' => '',
  'loglevel' => 2,
  'maintenance' => false,
  'trashbin_retention_obligation' => 'auto',
  'mail_smtphost' => '',
  'mail_smtpport' => '465',
  'mail_smtpname' => '',
  'mail_smtppassword' => 'XXXXXXXx',
  '' => 'stable',
  'updater.secret' => '$2y$10$xxxx',

Do you know how I can face the occ command on a Qnap TVS 463, since nextcloud is running on the server?

The occ-script should be in the parent directory of the config folder where you found the config file. Go to this directory. Then the command is like
sudo -u webserver-user php occ upgrade

I do not know how the webserver user in Qnap is called. You can check the owner of the files in your data-folder (ls -lisa /share/CACHEDEV1_DATA/.qpkg/owncloud/owncloud/data) which is very likely the webserver user. php can be named a bit differently, could also be php-cli php-7.0 (you can search for available programs with which php).

I tried to log in into occ but it is not working…

[/share/CACHEDEV1_DATA/.qpkg/owncloud/owncloud] # sudo -u webserver-user php occ upgrade          

sudo: unknown user: webserver-user
sudo: unable to initialize policy plugin
[/share/CACHEDEV1_DATA/.qpkg/owncloud/owncloud] #

Owner of the files should be admin or I am getting it wrong?

this looks like it should be sudo -u httpdusr …

tried but still get

[/share/CACHEDEV1_DATA/.qpkg/owncloud/owncloud] # sudo -u httpdusr php occ upgrade
sudo: php: command not found
[/share/CACHEDEV1_DATA/.qpkg/owncloud/owncloud] #

And which php gives me nothing…

[/share/CACHEDEV1_DATA/.qpkg/owncloud/owncloud] # which php
[/share/CACHEDEV1_DATA/.qpkg/owncloud/owncloud] #

So the php command is unkown. Check the qnap community how to run php scripts from terminal, perhaps you still need to install it ( or if it is just in some folder (not the main folder for programs):

In doubt, ask the qnap community.