NC UCS Appliance stuck in Maintenance-Mode

My NC 12 UCS Appliance is stuck in Maintenance Mode after updating it. I tried to deactivate Maintenance Mode by adding "maintenance" => false, into my config.php but that doesn´t work. I cannot work with the occ commands because my occ.php is not at the same location as discribed in the documentation of Nextcloud. locate occ.php doesn´t bring any results. Does anyone knows how to get out of maintenance-mode in the Nextcloud UCS Appliance?

I’m stuck with the same problem. 《maintenance => false》in 《config.php》is not working and there is no 《occ.php》on my nextcloud device.

However, there is a file named 《occ》 in 《/opt/app/nextcloud/nextcloud/》
I tried "《udo -u www-data php occ integrity:check-core》 (read that in another forum) but that just gives 《sudo: php: command not found》

My nextcloud 13 is syncloud based, by the way.

Any help with getting out of maintenance mode would be very appreciated.

Best regards,
Sebastian

stuck here with the same as far as I see it, based on Synology NAS I tried to upgrade via Web installer on stable release from 13.0.2 to 13.04 but first there was an error with the one point after the backup, something with http text and stuff, then the retry button was shown, ok so I did, but now in maintenance mode even I changed config.php.
The occ file I see but I do not know how to Access Synology via cmd so I could do some sudo stuff.
Any experience out there?
@Sebastian T: did you get around the problem?

I found no solution, wiped the drive, and made a new clean install.

I’ll make it a habit to make backups on a regular basis and before I change anything.

My whole nextcloud experience is very bad. I was hoping that this software would be so much more technologicaly mature. Now I see why there are so much more forum posts of people asking for solutions to their problems than there are tutorials. The only reason I don’t abandon this whole topic of hosting my own cloud is that I would lose the money I invested in the hardware.

sure enough anyone here is really providing any further detail about his/her set-up/environment/whatever. anyone is providing logs or simply anything that could give an interested person at least a hint where to begin with a solution.
but sure enough “the forum” alone is responsible for that, not answering on anything und thus sucking big times. that got very clear.

thank you guys. you really do cherish the voluntary work of all users here who spend their free/sparetime here just trying to help other ppl. for free. because the want to and not because someone forced them to help.

I consider myself a somewhat advanced Windows user meaning I fix issues with Windows based computers for my friends and family on a regular basis.

Most of the troubles I encountered over time could be solved by reading articles on websites. Rarely i needed to read on forums, but never ever was it neccessary to post any log files anywere.

I’m not used to post log files - this seems to be a Linux thing? I wouldn’t know which log file to post anyway. find -name "*log* in root gives hundrets and hundrets of results…

Do you have any advice which log file to post? Is there a source that would have told me which is the relevant one?

My disappointment is about nextcloud itself, not about the community. I remember how the nextcloud website said that it was not just for technical people but for everyone. I dare to say that the moment you leave the GUI this isn’t true anymore. In fact I encountered a button in the LDAP section of the GUI which broke my nextcloud beyond repair. Imagine Windows or Android being so vulnerable to inexperienced users.

I do appreciate it very much that so many people spend their valuable time here to help others.

well at first place you’re using NC as a part of UCS (as the thread-title here implies - but we don’t really know how and where you run your NC). so it could be a cool idea to post your questions there, right? because many UCS-users might have installed NC and would know how to deal with such problems. but you’re posting here… and we don’t really know how many users here are using NC as a UCS service.

well linux-world is different to windows-world. i daresay if you’re a common user with common needs (email, surfing, writing letters, maybe even streaming music and watching videos) you’d be happy with a (random) linux-system and you prolly won’t face any problems.

if you like to get into things (either b/c you run a uncommon hardware or have special needs) you should be aware that linux could turn out to be a bit more tricky than windows. you can tweak and twist your linux-system in a lot more ways than you’d do it with windows (though you can do that with windows as well, but how often do you interfere with the registration or setting up roles etc?)

don’t be too surprised that they managed to come very close to fulfil this promise, given that there are dozens of distributions (“versions” of linux) and possibilities on how to host a NC-instance. there must be some 10s of thousands NC-servers running in the whole wide world (i dunno of any exact numbers, could 100s of thousands as well) - and apparently the majority of it seem to run without any problems. if there are problems ppl would come here and post them. some of them won’t get any answer b/c there are not enough volunteers here (b/c it’s still a small community) or b/c they don’t provide any neccessary info that is asked for when you open a thread. and there are ppl just re-opening an old thread rather than posting a new one with a reference to the old one.

so as for you @SebastianT, i personally got the impression that you might not really run NC as an UCS-application, right?

cheers
jimmy

Hi @SebastianT, I found that my system tells me step 4 is still running… searching that in Nextcloud forum helped.
As far as I see it I had an issue with the backup which shouldn’t as the USB drive is half full so enough space at least. After starting the cmd line with telnet to Synology NAS it worked out to stop maintenance mode, then running web interaface told me step 4 is still ongoing… since more than 24 hours? Ok looking for that immediately helped.


So I hope this helps others as well. Wasn’t to easy but also not very complicatged to start Telnet in Synology, and use standard Win 7 client and login as standard user and change do super user with sudo then php56 instead of only php and my -u (user parameter) should be http for us Syno guys.