NC Talk with HPB, Unable to start conversation (button greyed out)

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 23.0.4
Operating system and version (eg, Ubuntu 20.04): Ubuntu 18.04.6 LTS
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.29
PHP version (eg, 7.4): PHP 7.4.10 PostgresSQL version_: .10.21’

The issue you are facing:
Since installing and connecting the High Performance Backend as per this tutorial:
(How to Install Nextcloud Talk High Performance Backend with Stun/Turnserver on Ubuntu – Markus' Blog)

i’m unable to setup calls. In the web interface the button is inactive (greyed out) and when i start a call via the Android App nothing happens on te receiving side.

Steps to replicate it:

  1. install and connect the signaling server (all settings seem OK)
  2. create a conversation

The output of your Nextcloud log in Admin > Logging:

GuzzleHttp\Exception\ClientException: Client error: `POST https://communicate.kraaijvanger.nl/standalone-signaling/api/v1/room/38r73kyz` resulted in a `400 Bad Request` response: Unsupported request type:

    /var/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Middleware.php - line 69:

    GuzzleHttp\Exception\RequestException::create()

    /var/www/nextcloud/3rdparty/guzzlehttp/promises/src/Promise.php - line 204:

    GuzzleHttp\Middleware::GuzzleHttp\{closure}("*** sensiti ... *")

    /var/www/nextcloud/3rdparty/guzzlehttp/promises/src/Promise.php - line 153:

    GuzzleHttp\Promise\Promise::callHandler()

    /var/www/nextcloud/3rdparty/guzzlehttp/promises/src/TaskQueue.php - line 48:

    GuzzleHttp\Promise\Promise::GuzzleHttp\Promise\{closure}("*** sensiti ... *")

    /var/www/nextcloud/3rdparty/guzzlehttp/promises/src/Promise.php - line 248:

    GuzzleHttp\Promise\TaskQueue->run()

    /var/www/nextcloud/3rdparty/guzzlehttp/promises/src/Promise.php - line 224:

    GuzzleHttp\Promise\Promise->invokeWaitFn()

    /var/www/nextcloud/3rdparty/guzzlehttp/promises/src/Promise.php - line 269:

    GuzzleHttp\Promise\Promise->waitIfPending()

    /var/www/nextcloud/3rdparty/guzzlehttp/promises/src/Promise.php - line 226:

    GuzzleHttp\Promise\Promise->invokeWaitList()

    /var/www/nextcloud/3rdparty/guzzlehttp/promises/src/Promise.php - line 62:

    GuzzleHttp\Promise\Promise->waitIfPending()

    /var/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php - line 187:

    GuzzleHttp\Promise\Promise->wait()

    /var/www/nextcloud/lib/private/Http/Client/Client.php - line 294:

    GuzzleHttp\Client->request()

    /var/www/nextcloud/apps/spreed/lib/Signaling/BackendNotifier.php - line 87:

    OC\Http\Client\Client->post()

    /var/www/nextcloud/apps/spreed/lib/Signaling/BackendNotifier.php - line 141:

    OCA\Talk\Signaling\BackendNotifier->doRequest()

    /var/www/nextcloud/apps/spreed/lib/Signaling/BackendNotifier.php - line 407:

    OCA\Talk\Signaling\BackendNotifier->backendRequest()

    /var/www/nextcloud/apps/spreed/lib/Signaling/Listener.php - line 296:

    OCA\Talk\Signaling\BackendNotifier->roomInCallChanged()

    /var/www/nextcloud/3rdparty/symfony/event-dispatcher/EventDispatcher.php - line 251:

    OCA\Talk\Signaling\Listener::OCA\Talk\Signaling\{closure}("*** sensiti ... *")

    /var/www/nextcloud/3rdparty/symfony/event-dispatcher/EventDispatcher.php - line 73:

    Symfony\Component\EventDispatcher\EventDispatcher->callListeners()

    /var/www/nextcloud/lib/private/EventDispatcher/EventDispatcher.php - line 88:

    Symfony\Component\EventDispatcher\EventDispatcher->dispatch()

    /var/www/nextcloud/apps/spreed/lib/Service/ParticipantService.php - line 966:

    OC\EventDispatcher\EventDispatcher->dispatch()

    /var/www/nextcloud/apps/spreed/lib/Controller/CallController.php - line 172:

    OCA\Talk\Service\ParticipantService->changeInCall()

    /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 217:

    OCA\Talk\Controller\CallController->leaveCall()

    /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 126:

    OC\AppFramework\Http\Dispatcher->executeController()

    /var/www/nextcloud/lib/private/AppFramework/App.php - line 157:

    OC\AppFramework\Http\Dispatcher->dispatch()

    /var/www/nextcloud/lib/private/Route/Router.php - line 302:

    OC\AppFramework\App::main()

    /var/www/nextcloud/ocs/v1.php - line 62:

    OC\Route\Router->match()

    /var/www/nextcloud/ocs/v2.php - line 23:

    require_once("/var/www/nextcloud/ocs/v1.php")

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'passwordsalt' => '********************************',
  'secret' => '******************************************',
  'trusted_domains' =>
  array (
    0 => 'localhost',
    1 => 'server.domain.com',
    2 => 'nextcloud.domain.com',
  ),
  'datadirectory' => '/mnt/ncdata',
  'dbtype' => 'pgsql',
  'version' => '23.0.4.1',
  'overwrite.cli.url' => 'http://localhost',
  'dbname' => 'db_name',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'dbuser',
  'dbpassword' => '****************************',
  'installed' => true,
  'instanceid' => '*************',
  'log_type' => 'file',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'loglevel' => '2',
  'mail_smtpmode' => 'smtp',
  'remember_login_cookie_lifetime' => '1800',
  'log_rotate_size' => '10485760',
  'trashbin_retention_obligation' => 'auto, 180',
  'versions_retention_obligation' => 'auto, 365',
  'simpleSignUpLink.shown' => 'false',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'filelocking.enabled' => true,
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => 0,
    'timeout' => 0.5,
    'dbindex' => 0,
    'password' => '********************************',
  ),
  'maintenance' => false,
  'ldapIgnoreNamingRules' => false,
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'theme' => '',
  'default_phone_region' => 'NL',
  'mail_from_address' => 'admin',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'domain.com',
  'mail_smtphost' => 'mail.domain.com',
  'mail_smtpport' => '25',
  'mail_smtpauth' => 1,
  'mail_smtpauthtype' => 'NTLM',
  'mail_smtpname' => 'whoever',
  'mail_smtppassword' => '*************************',
 'updater.release.channel' => 'stable',
);



Same problem here. Tried everything I found, but nothing worked for me.
Hope for a solution.