NC on Synology NAS with DSM 6.1, PHP7, NGINX and PostgresQL

I’ve got NC (12.0.5) installed (migrated) on a Synology NAS (DSM 6.1) but with a somehow peculiar setup :


Everything working for mobile syncing (files/caldav… )
But for my computer (opensuse and plasma) I get an error trying to add caldav.
I get http error 405 (from nginx log, when a propfind request is done) when I try to add the calendar from akonadi.

File syncing is working, though, on the desktop side.

On the admin UI I have only one annoying warning about php getenv path returning and empty response.

Has anybody had similar issues, and / or could give some directions on how to solve them?

Everything working, was a problem on some config. Only thing is I still get php getenv path warning . I am on NC 15, about to update it to 16.

Performance suffers a bit through web UI, but otherwise sync work.

Some issues with Notes apps (Android) syncing, creating duplicates of notes; and also because of absent way of generating thumbnails (the php extension for imagemagick is not available for this setup as far as I tried to learn)