NC on shared webserver; no trusted domain; no access to config.php

I am trying to run NextCloud onto a shared webhosting server.
When I enter the URL, NC tells me to edit config.php, but I can’t edit it,
Is there another way to tell the shared server my domain is a trusted domain?


Hello Guido,

how have you been able to install Nextcloud without access to any files?

If you are able to login via a default domain like local IP adress you can do the following:

Open Nextcloud with the URL that works and login as admin. Then open Nextcloud with URL that doesnt work and you should see a site with a button like “add to my trusted domains” and then you have to replace the first part of the URL with the default address that works.

Afterwards your new domain should be treated as trusted.

Hello Norros,

Most of the problems are solved.
In the manager’s section (I do not know the English name) I see three issues to solve:

  • The “Strict-Transport-Security” HTTP header isn’t configured at minimal 15552000 seconds
  • memcache is not defined
  • opcache is not defined

Can you help me to configure these issues on my system?


Advance host providers would allow custom php settings or directives for the web server.

If you have those, you can workout must of them.

Hi @Guido_van_Harten Guido,

This is a strict https forwarding for anbody who has visited the site via https bevore. If you forward this in the apache config, or port 80 is closed altogether, than, you may omit this. Also it may hinder you when you try to access your site via port 80 for testing purposes, as it will automaticly redirect you to https for the next 15552000 seconds.

These are performance optimisation measures. Its purly your decision whether you configure them.
If you want to, you can find a guide here: