NC extremly slow while uploading big files

Nextcloud version: 22.1.1
Operating system and version: Ubuntu 20.04
Apache or nginx version (eg, Apache 2.4.25): Apache2.4.41
PHP version (eg, 7.4): PHP 8.0.8

I have a LAMP-Stack running and i have the issue that while i upload big files to the cloud, the performance of the whole could goes down.
It is hosted on a vServer in a Datacenter vom IONOS with 400Mbit symettrical up and download.

Any idea what it could be and how to resolve that issue?

Is this the first time you’ve seen this error? (Y/N): N

When i am uploading the same amount of data via SFTP there are no issues while using the cloud.

You haven’t really provided any information for a starting point.
What do you mean by “performance”? Are you looking at CPU load? Network load? Is the memory swapping?

  • Do you have Antivirus App enabled?

How do you upload files?

  • Via client?
  • Via UI?
  • Via WebDAV?

I don’t use any kind of Antivirus.

It gets slow when i am using the UI in the Browser and Cyberduck (WebDAV) as a client.
With the official Nextcloud-Client i don’t noticed any problems yet.

When U upload, what is “extremly slow”? Is this 100 Mbps? Or 20?
Did you check Server Memory and CPU usage when upload?

No not directly the networkspeed. The whole Nextcloud-Website is not really browsable and the loading times are extrem long.

Memory Swapping? How could i check this?

The Memory is enough and the CPU isn’t the problem as well…

How about looking at the output of the free command?

1 Like

Nothing special at this point. Here a Screenshot from the Ressources while i am uploading.

Bildschirmfoto 2021-10-12 um 19.20.45

Ok, so resource utilization is looking pretty low. Suggests that you might be dealing either with a network limit or a queuing issue. A queuing issue might be caused by something like insufficient “max_children” in php.

However, I’m also now thinking about your “remote” network connection. So you have your nextcloud server running somewhere with symmetric 400 Mbps. But what about the where you are accessing it from while you are doing your upload test? Are you running a “big upload” from one client-side network and running your UI performance test from the same network? Or are you running from two separate client-side networks?

Here’s what I’m getting at; if you are doing both the upload and UI performance test from the same network, then the upload is probably saturating your upstream network, which is what is causing you poor performance. Not your server. A lot of cheap home routers do a terrible job of allocating bandwidth to short requests.

Look into bufferbloat;

Thank your for the advice but i tried that.
I uploaded from one network and tried to use the UI from another Network… same problem.

What i am wondering is, that the problem only appears when i try to upload big and many files with Cyberduck or over the Gui. With the Nextcloud-Client i have no issues…
And when i am uploading the same amount of data directly to the server over SFTP i have also no problems.

Then you need to look at php and apache process limits, mariadb connection and process limits, queue settings on the server, etc.

1 Like