NC 28.0.1 Final

Thanks for the fast fixes.
Now it is time for me to update my NCs.

@skjnldsv Merry Christmas :christmas_tree:

1 Like

Drag and Drop still not fixed! It will be fixed in 28.0.2 scheduled for January.

3 Likes

I just got the mail about the Version 28.0.1.
When I update my Nextcloud-instance (via the web interface) I got an upgrade to 27.1.5, but 28.0.1 is not offered.
How can I upgrade to that version?

UPDATE: I just read that the version is deployed in several “waves”. So I just have to wait, I think. That’s a good idea; so many errors while updating (again). My installation crashed several times in the past.

1 Like

First update to the latest release of the currently installed version. After that you will more likely be offered the next major release.

Hi

Wel Iam trying it out as wel speak . I found 2 things

1 User mutation.It seems not possible to mutate a user . Changes are not saved
2 The bookmap app is not working when trying to add a map to the boookmarks app
klikking om a specific map doesnoot filter out the bookmarks of a specific map . I guess the whole poind of adding maps is to bring some order .

For your info > Iam running it on a cheep hosting plan with 50 or 100 gb space
So far this is what I have done
Iam am going to try on my fourth hosting partner . The last one did kind of a good job . I need a bit more speed and relyability as sometimes it does run fine and sometimes it doesnot run at all

Tried hostinger. Was fine using insaller . But their insaller had an older version. The platform was fast though
then I tried one that was to expensive butwas doing ok ( to little space was the main issue ) enough space was getting to expensive
Then I tried web reus in holland . Nice 50 GB space and no limits at a good price. As said it need s more relyability as I need to use the converance bit and the chat app to be working properly

Now Iam going to try an other one

regards

Renko Allard van der Molen

.

HTML 500 after web updater ran. I’ve posted a request for help here.

In my instance the same happened. v28.0.1 only announced via CLI. But be careful! My upgrade has led to an unusable NC. I was running on Debain 11 and after the update to v28.0.1 an internal server error appeared. And there are a lot error messages in the nextcloud.log.

So far I found that it is better to upgrade from Debian 11 to Debian 12 and check the following things:

  1. apt-utils installed? If you need to install php-bz2 (see point 2) you need to have this installed first
  2. php-bz2 installed? This package seems to be necessary in order to install the apps

I implemented a Turnkey Linux Nextcloud appliance (Debian 12 and NC v27.1.1) to analyze what happens. Upgrade to v27.1.5 worked well. Upgrade to v28.0.1 seemed to work as well but there are error messages in the nextcloud.log And the admin screen tells me, that I have to install php-bz2. I’m still investing the case and I won’t upgrade my other production environment so far.

I have updated over 10 systems on Debian. All from Debian 10 +sury to debian 12. All of them worked like a charm.

Same with soon over 10 Ubuntu based systems as well.

I have had a few broken ones due to third party apps. Or in one case a failed upgrade earlier with apparently skipped a few migrations at that time.

Which NC version did you use? NC All-in-one or other?

Manual install on Debian. Manual on Ubuntu and the Nextcloud vm.

A few had been updated from 26 to 27 then to 27 28 but most of them from 27.1.4 and 27.1.5

I only run AIO for testing now and then I don’t have any permanent install of it.

dav No calendar events found for status check

I updated to version 28.0.1, it gives this error, how is the solution?

I am a lite bit disappointed by this version.
I never had so many errors in log (100 per day !), even with an installation made from scratch, not a migration. With version 27, no error !
In SAFARI it’s not possible to scroll in the Application panel.
The connection frame has changed with surimposition of “User name…” and “Password” which is not necessary and “heavy”.
Sometime the cron task takes a very long time to end…
The icons in the file view are less clear than in the previous version.
I migrated from 27.1.3 to 28.0.1 and, with all this problems, even after migration or with a fresh installation, I decided to restore my backup and to migrate from 27.1.3 ti 27.1.5 which is more stable from my point of view.

1 Like

28.0.1 No errors at all. Docker installation (update from 27.something):

  app:
    image: nextcloud:28.0.1-fpm-alpine

For your own interest, check if these error were reported at Issues · nextcloud/server · GitHub, so that there is a change that they will be fixed while you still work on NC27. You might think these errors are obvious, if they had happened for the developers, they would have fixed them.

1 Like

A post was split to a new topic: DiscoveryService::refetch() error in richdocuments after upgrade to NC28

My Docker installation still doesn’t have a single error. Everything works fine. The installation is not ‘all-in-one’ like many here, but the simplest one (behind a reverse proxy). It is roughly as described here:
docs/nextcloud/README.md at master · docker-library/docs · GitHub

For individual issues, please open a new topic and fill out the template.
I’m closing this thread here.

I see a lot of errors in the log file after updating to version 28

I still haven’t had a single error since December 23 when I updated Nextcloud to version 28.0.1. Apparently the errors are showing up in your ‘all-in-one’ version. I have no errors in my simple installation based on image 28.0.1-fpm-alpine.

Good for you, but why did you feel the need to post this twice in a news thread?

Oh, and by the way, other people use more complex setups than the “simple” Docker install, with additional apps besides “Files”, and so does AIO, and there are definitely still some issues in 28, even with “featured” apps.