NC 27 - Files not shown in WebUI

The web UI of Nextcloud would not show any files and is stuck on the loading indicator.
When looking into the browser logs I get this error message:

Unhandled Promise Rejection: TypeError: undefined is not an object (evaluating ‘n.propStat.length’)

Debugging the error location gives me the following result:

Here somehow the response variable is not correctly set!

The xml file, which is parsed in this function is pulled from SERVER/remote.php/dav/files/test/:

<?xml version="1.0"?>
<d:multistatus xmlns:d="DAV:" xmlns:s="" xmlns:oc="" xmlns:nc="">
                <d:getlastmodified>Fri, 02 Feb 2024 15:14:50 GMT</d:getlastmodified>
                <x1:share-permissions xmlns:x1="">15</x1:share-permissions>
            <d:status>HTTP/1.1 200 OK</d:status>
            <d:status>HTTP/1.1 404 Not Found</d:status>

It’s a valid xml file.
Why is my Nextcloud instance broken? The problem appeared out of the blue.
I also tried updating Nextcloud and installing it from scratch.
iOS App is working fine and showing all files. Also everything else of Nextcloud is working fine (Settings, Fotos App, App Configuration, …) Just everything in the files app is broken.

Browser: Safari / Chrome

Could anyone help me, why my nextcloud instance is broken and will not work anymore?

@emajagroutiptinv - Sorry I can’t help you because I have the same issue. And I am using 28.0.2, which makes it appear that this issue isn’t just in your version of Nextcloud. I can access some files on some of my external disks, but I can’t access other files and folders on the same disks. I’ve checked the permissions and there are the same permissions on files in folders that I can access as there are on other files in the same folders that don’t appear in the Files listing in Nextcloud. Have others come across this issue before? I’ve been using Nextcloud for quite a few years now on the same RPI4 and the same USB-attached disks as are now showing this issue. And this issue has never appeared before.

My issue has been resolved. It appears to be some database corruption, which I fixed by running occ files:scan. This returned all lost files to the Web gui.

Unfortunately my problem is not resolved with this step. I already did that but still getting the same result on the UI