NC 21.0.5 : no update channel available [SOLVED]

Hello all

After updating to NC 21.0.5 from 21.0.4 (and reboot) the page Settings/Overview/Version no longer shows any update option. Only the version is shown.
On that page there should be an option to select the update channel, and update.

  1. Is this a bug ?
  2. how to update NC in the future ?


Please, can anyone assist ?
No update option available in 21.0.5
No errors in log

NC 2105 mising update function

If you have command line access, you can try to run from command line, so you get perhaps a bit more information (in case of connection problems):

sudo -u www-data php updater/updater.phar

If it’s related to the updater app, perhaps in the app overview, there are app updates (and perhaps the updater app).

If all that does not work, or it takes to much time, you can do a manual upgrade. The updater app mainly downloads the new version and unpacks the files. Please backup before, then you delete all the code, meaning you keep just the data and the config folders. Then download the latest NC 21 version: and unpack the files and folders. Make sure the permissions are set correctly. More detailed step-by-step guide:

Thanks a lot,
That .phar command does the trick, can update to 22.2.0. (and decided to wait a bit before apply)

While on the commandline running ncp-config I get a version issue:
[ncp-config], [Updates], [nc-update-nextclou], version [0]

  • Current Nextcloud version
  • Available Nextcloud version 21.0.4

That’s inconsistent with the result of the previous command, that showed 22.2 as most recent version. Is that worth reporting to the developper of the ncp-config tool ?

Well, what a surprise… Problem is solved… read abt same problem elsewhere on the forum

The “Update Notification App” got disabled at the last update to 21.0.5.

Re-enabled it.

NC 2105 mising update function fixed