NC 16.0.5->17.0.1 Upgrade - File Integrity check failed

Support intro

Nextcloud version (eg, 12.0.2): 17.0.1
Operating system and version (eg, Ubuntu 17.04): 18.04.3
Apache or nginx version (eg, Apache 2.4.25): 2.4.25
PHP version (eg, 7.1): 7.2

The issue you are facing:

File integrity check fails after upgrade to 17.0.1
At first the check complained about an extra file:

  • files_rightclick

So I deleted that file. Now it complains about missing of exact that file (same hash).

I downloaded the Nextcloud 17.0.1 package and there should not be a in that folder. So everything should be fine, but…

Is this the first time you’ve seen this error? (Y/N): y

Steps to replicate it:

  1. Upgrade from NC 16.0.5 to 17.0.1 (via updater)
  2. Click on Preferences
  3. Click on Overview
  4. (rescan)

The output of your Nextcloud log in Admin > Logging:

- files_rightclick

Raw output
    [files_rightclick] => Array
            [FILE_MISSING] => Array
                    [] => Array
                            [expected] => 008148d723136644c2542312557ed5b9db1af5de6797a221d221012ae0ad367b2daca4774bcaba8936ec8394093b83c3e3f2d8e7c52e5f5882e28579dffe99e2
                            [current] => 




The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


The output of your Apache/nginx/system log in /var/log/____:

1 Like

Using the wonderful search function in the upper right corner of this forum should usually help you finding and answer on this kind of request :wink:

See e.g.

YES, there is a wonderful search function which I used and there are lots of cases where there are too much files (which should not be there -> delete them) or too less files (which should be there usually -> copy them from the original package to the folder). Once you know that -> easy.

BUT this case is a bit more special: The integrity check first complained about a file which should not be there ( -> extra file). I deleted that file.
And now the integrity check complains about exactly this (same hash!) which I deleted is missing.

The point is: The integrity check is missing a file which should not be there and is not there (because I deleted it before because the integrity check complained about it…).

Unfortunately I did not find anything like this via the search function.
So any help is appreciated.

Download the Right click app archive file and extract the missing files to the ./apps/files_rightclick directory. I wasn’t able to find a file in the v0.14.2 app archive but in the v0.15.1 one.

1 Like

OK, I tried that before, but did it again and after 2-3 rescans THIS message is gone!

BUT now it complains about my .htaccess (which I changed after upgrading to 17.0.1, see below):

Technical information

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix


  • core
      • .htaccess

Raw output

[core] => Array
[.htaccess] => Array
[expected] => c98ec6c839cd1c86e69900c8dbc2fe457b6fd7d6ae626cfa6247b1774dfac1444b2d9cfbc0060af2a891c10d74bc0acfbf8b70f341db05429825eabf2a406bff
[current] => 94b9bbe33918d456eb1a96069c8a1cbcf241f8328648f1b53c477f3e5e2e94c953c875db424cd8f29693b479f23d76a51703c4fac7a85be6eb7e01803f59674b




Already tried to replace the .htaccess with an old one from my backup and tried: sudo -u www-data php /var/www/nextcloud/occ maintenance:update:htaccess

Both with no success.

If I copy the original .htaccess from the nextcloud 17.0.1 package, that does not work at all. No website…
If I add the additional lines from my old .htaccess it works again but it complains again about the hash (see above)

And now (MAGIC!?) after changing something in my apache configuration (/etc/apache2/sites-available/nextcloud.conf) and 2-3 rescans everything is fine.

I don’t understand that at all, but it’s solved now.

After reading this thread I went to my apps page and Right Click said “Update to 0.15.1”. After the update the error was still showing up. I restarted nginx and php7.2-fpm - the error still was displayed. But after clicking “re-scan” link on the settings page (after the error), the error disappeared. Not sure if restarting nginx and php7.2-fpm was even necessary.