NC 13 AND PHP 7.2 (config php.ini)

Hi Everyone!

I have maybe or not an issue, in my nextcloud “Security & setup warnings”, I have the warning about PHP.INI “is not properly configured”, but I fixed this configuration on php.ini, I atacched the warning on printscreen below.

Anyone can help-me with this alert?


Did you restart your web server?

Hi, yes I restart my web server, but not solved.

thank you!

Your opcache settings may be in the other .ini file.
Type php --ini and you’ll see all .ini files in use. Start from the bottom and look for the lines like in the your pic. If you find similar lines, edit them.
Then reboot or restart php-fpm and nginx/apache.

Do you use php or php-fpm?
Normally the ini file in question for 7.2 is around /etc/php/7.2/apache2/php.ini

Hi MeiRos, thank you for your help, let me see this process and after I show to all here.

Hi Jason, I changed the configuration on the same path. ( /etc/php/7.2/apache2/php.ini )

In some O.S. you can see the settings to opcache in other folder and file like this:

/etc/php.d/10-opcache.ini or similar

put that settings in that file and restart or reload your web server.

1 Like

I finded this file in this path below on print screen, i need put the below settings in this file?



Looks good. At least I have the settings below the line ‘’. So, I think that’s the right place.

Good, but maybe i put wrong the settings, see bellow. Is your file like this? The warning continues on my admin status. =/


Uncomment lines. Delete ; before opcache settings. Leave 1. and 2. line like they are.

1 Like

MeiRos Thank you for your help, the warning is solved!

Thank you all for your help!

1 Like