Nach UpGrade auf Debian 10 Fehlermeldung 'PHP-Modul cURL nicht installiert'

Guten Tag Community,

ich bin am verzweifeln…

Habe gestern ein UpGrade auf Debian 10 gemacht und seit dem läuft meine Nextcloud 14 - Installation nicht mehr.
Wenn ich die Cloud-Seite aufrufe, dann bekomme ich die Meldung:
Fehler
PHP-Modul cURL nicht installiert.
Bitte für die Installation des Moduls Deinen Server-Administrator kontaktieren.
PHP-Module wurden installiert, werden aber als noch fehlend gelistet?
Bitte kontaktiere Deinen Server-Administrator und bitte um den Neustart des Webservers.

Mein System ist ein root-Server mit aktuellem Debian 10, Apache 2, PHP 7.3 und aktuell Nextcloud 14.0.4

Seit gestern Vormittag recherchiere ich mir den Wolf und hab folgende Seiten durch:

PHP 5.6 wurde mittels apt purge 'php5.6’* von der Platte gefegt.

PHP 7.3 - Module wurden nachinstalliert (inkl. PHP7.3-curl)

PHP 5.6 wurde mittels a2dismod php5 deaktiviert und PHP 7.3 mittels a2enmod php7.3 aktiviert.

In /etc/php/7.3/fpm/pool/www.conf wurden die Variablen wie folgt gesetzt:
env[HOSTNAME] = $HOSTNAME
env[PATH] = /usr/local/bin:/usr/bin:/bin
env[TMP] = /tmp
env[TMPDIR] = /tmp
env[TEMP] = /tmp
clear_env = no

Ausgabe von printenv PATH :

/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

Apache 2 mittels systemctl restart apache2 neu gestartet.

Ausgabe von php -v :

PHP 7.3.7-1+0~20190710.40+debian10~1.gbp032aec (cli) (built: Jul 10 2019 07:37:20) ( NTS )
Copyright © 1997-2018 The PHP Group
Zend Engine v3.3.7, Copyright © 1998-2018 Zend Technologies
with Zend OPcache v7.3.7-1+0~20190710.40+debian10~1.gbp032aec, Copyright © 1999-2018, by Zend Technologies

… die gesamte Kiste wurde nach dem UpGrade auf Debian 10 natürlich neu gebootet ^^ …

[Error-]Logs bringen nichts zutage.

Problem(meldung im Browser) bleibt weiterhin bestehen :frowning:

Was habe ich vergessen/übersehen?
Danke im Voraus.
LG
worker

Ist die aktuelle Version nicht 16.0.3? Kann es sein dass 14 Probleme mit der PHP Version hat? Es gab mal einen Fall da lag es an der Datenbank und ein kompletter Systemneustart war die Lösung, haste aber gemacht. Dein geposteter Befehl hat aber 7.0 aktiviert, nicht 7.3 oder?

Äh … das mit dem a2enmod php7.0 war ein Vertipper - sorry :slight_smile:
Ich hab’ schon 7.3 in der Shell reingetippselt ^^

Ja, ich weiss, dass ich mit der 14er - Version nicht auf dem Laufenden bin. Dies wollte ich auch als nächstes angehen. Doch jetzt wo sich solche Probleme nach dem UpGrade gezeigt hatten, wollte ich “langsam mit den jungen Pferden :-D”.
Keine Ahnung ob die 14er Probleme mit PHP 7.x hat. Jedenfalls danke für den Gedankenanstoss. Werde mal recherchieren …

Gemäß den Systemanforderungen für Nextcloud 14 werden nur die PHP-Versionen 7.0 - 7.2 unterstützt. PHP 7.3 wird erst ab Nextcloud 15 unterstützt.

Um die Meldung bezüglich des fehlenden PHP-Moduls los zu werden, empfehle ich die Installation des selbigen. Das benötigte Debian-Paket heißt vermutlich php7.3-curl.

@j-ed:
Vielen Dank für die Infos, betreffend der Nextcloud- & PHP-Version-Kompatibilität.

Wie ich bereits schrieb, habe ich php7.3-curl installiert - es hat an der Meldung nichts geändert.

Ok, nachdem das Modul installiert wurde musst Du natürlich sicher stellen, dass es auch geladen wird. Hast Du dies geprüft? Wenn ja, wie? Üblicherweise gibt es jeweils getrennte Konfigurationen für das PHP CLI und den PHP WEB-Zugriff.

Nun geladen und entsicher scheint es zu sein.
Jedenfalls zeig mir ein php -m an, dass es geladen ist.

Üblicherweise gibt es jeweils getrennte Konfigurationen für das PHP CLI und den PHP WEB-Zugriff.

Meinst du damit jetzt PHP, oder Nextcloud?
Kannst du das bitte etwas näher erläutern?

Um zu prüfen, ob das PHP-Modul korrekt geladen wird, geht man wie folgt vor:

  • CLI: “php -m” an der Konsole ausführen. Dies hast Du geprüft. :heavy_check_mark:

  • WEB: Eine PHP-Datei auf dem Server erzeugen, welche als Inhalt “<?php phpinfo() ?>” hat. Anschließend diese Datei mit einem Webbrowser öffnen und schauen, ob das Modul korrekt geladen wurde. Üblicherweise wird dann ein solcher Block angezeigt:
    grafik

Aha …
In der Ausgabe von <?php phpinfo() ?> steht nirgends cURL support oder cURL Information.
Lediglich eine Zeile spuckt etwas von cURL aus:

cURL Sterling Hughes

Das war’s.

Nachtrag:
Doch in der Datei (Verlinkung) /etc/php/7.3/apache2/conf.d/@20-curl.ini steht:
; configuration for php curl module
; priority=20
extension=curl.so

Müsste also aktiviert sein…?

Wenn es in der Übersicht nicht angezeigt wird, wurde das PHP-Modul nicht geladen. Da ich selbst kein Debian-System verwende kann ich Dir leider nicht sagen wie die Dateien und Pfade heißen in denen gegebenenfalls eine Anpassung durchgeführt werden muss.

Halt, da stimmt was nicht …
Hab erst jetzt gesehen, dass bei der PHP-Info - Ausgabe in der Zeile “Additional .ini files parsed” nur Files stehen, die die Version 7.0 haben … kopfkratz … wie ist das denn nun möglich??

Okay. Danke trotzdem. Hast mich schon weiter gebracht :wink:

Dann wird vermutlich noch die falsche PHP-Library beim Start des Apache2 herangezogen. Es sollte eine Datei /etc/apache2/mods-available/libphp7.load o.ä. geben, in der festgelegt wird welches Version beim Start geladen wird.

1 Like

Uffff … geschafft! :smiley:

Hast recht gehabt @j-ed
Iwie hat das erste a2enmod php7.3 wohl nicht “gegriffen”.
Habs nochmal “enabled” und noch ein a2enmod mpm_prefork da in der Datei /etc/apache2/mods-enabled/@php7.3.load “Depends: mpm_prefork” stand. Eigentlich war die Rückmeldung des Befehls, dass es bereits “enabled” ist/war.

Naja, wie auch immer - Nextcloud scheint erstmal wieder zu laufen.

Danke vielmals @ll :+1:

@worker: ich hänge auch gerne mit Aktualisierungen hinterher :wink: Bin auch gerade beim Debian Upgrade, habe aber Nextcloud 15. Habe gerade versucht php7.3 zu installieren, aber irgendwie kann ich das Modul nicht mit

a2enmod php7.3 

laden.
Kommt die Meldung, dass das Modul nicht gefunden wird, und unter /usr/lib/apache2/modules finde ich kein Modul für php7.3 - nur für 7.0 (das hatte ich vorher schon installiert). Bei der Installation sind mir so nur keine Fehler aufgefallen…
Hast du zufällig noch die Quellen in deiner sources.list ?

Vielen Dank und viele Grüße
Melanie

ok - habs beheben können. Das Modul hatte ich nicht installiert. Also nach einem
apt-get install libapache2-mod-php7.3

kann ich das Modul dann auch laden.