Nach Update keine Anmeldung ├╝ber Webseite

Hallo zusammen,
nach meinem Update kann ich mich nicht mehr ├╝ber die Webseite anmelden.
Ich erhalten diese Meldung:

## Zwei-Faktor Authentifizierung

**Es konnte nicht eine Ihrer Zwei-Faktor-Authentifizierungsmethoden geladen werden. Kontaktieren Sie Ihren Administrator.**



**Die Zwei-Faktor-Authentifizierung wird erzwungen, wurde f├╝r Ihr Konto jedoch nicht konfiguriert. Verwenden Sie zum Anmelden einen Ihrer Backup-Codes, oder wenden Sie sich f├╝r Unterst├╝tzung an Ihren Administrator.**

Da ich Zugang per SSH habe wollte ich fragen ob ich auf diesem Weg die Anmeldung aktivieren kann.
Ich habe schon versucht, die Apps umzubennen, leider ohne Erfolg.

Habe ich hier M├Âglichkeiten?

Gru├č Lockslay

Hallo zusammen,
keiner eine Idee?.. Gru├č Lockslay

Hallo,

ich habe hier eine Anleitung gefunden wie man ├╝ber die Konsole sich einen neuen Code erzeugen kann:
Hier die Seite: https://www.bitblokes.de/nextcloud-15-zweifaktor-authentifizierung-2fa-erzwingen/
und hier der ben├Âtigte Befehl:

sudo -u www-data php occ twofactorauth:admin:generate-code

ich bekomme aber immer diese Meldung:

sudo -u www-data php occ twofactorauth:admin:generate-code lockslay

There are no commands defined in the ÔÇťtwofactorauth:adminÔÇŁ namespace.

Kann mir hier einer sagen was hier falsch ist?

Hallo Lockslay,

ich habe das gleiche Problem nach einem Update, welches ich gestern ├╝ber die Weboberfl├Ąche durchgef├╝hrt habe. Konntest du das Problem schon l├Âsen? Bzw. hat jemand eine Idee?

Ich habe f├╝r mich eine L├Âsung gefunden:

Im Verzechnis var/www/nextcloud den Befehl sudo -u www-data php occ twofactorauth:enforce --off ausf├╝hren.

Dadurch wird die Zwei-Faktor Authentifizierung nicht mehr erzwungen

1 Like

Ich hatte das Problem eben auch.
MIttels sudo -u http php occ app:list konnte ich feststellen, dass twofactor_u2f mit dem Update disabled wurde.

Dies lies sich mittels sudo -u http php occ app:enable twofactor_u2f leicht wieder beheben.

Vielleicht hilft es dem einen oder anderen.