My first post. problem with remote access - “access through untrusted domain” Please see documentation

I installed next cloud on my pi5 using the guide on Novaspirit.
It’s up and working.

I have a major problem
I can use it locally on localhost:5443 I can’t use the app as it says
“access through untrusted domain” Please see documentation.

I guess I have to add ssl certs to the server.
Is there a guide to do this? I’d like to use Let’s encrypt or another free service.

Thanks in Advance


take this :slight_smile:

1 Like

I installed next cloud on my pi5 using the guide on Novaspirit.

Don’t forget that just because you used some third-party guide, it doesn’t mean there isn’t official documentation also available. :slight_smile:

1 Like

I’m a bit new to this docker. How do I find the config.php.
I’ve tried a find from the root of the disk and /var/www etc. but can’t find it.

Can I set up ftp or ssh to this web server?

Sorry if these are reall N00B questions.

I tried attaching a console, but another error message

I can ping these 172.19 servers ,but can’t ssh to them either. How can I enable ssh?

Is there a primer I should read?

I found this
docker run -u 0 --rm -it linuxserver/nextcloud:latest /bin/bash

I found a config.php below

May you take one step by the other? Could you change the config.php you have found?

1 Like

I don’t really know what I’m doing.

Yes, but when I exit
There is another instance on a new ip address and without the access port of 5443

This is the new config.php (I’ve redacted my domain)

<?php $CONFIG = array( 'datadirectory' => '/data', 'trusted_domains' => array( 0 => '', 1 => 'nextcloud.local', 2 => '' ), ); What do I need to do?