My existing Collectives vanished after upgrading from Nextcloud 22.0 to 22.1

I’ve been trying out the Collectives app since they were mentioned along with the 22.0 release. I’ve made a couple of collectives, put a few pages in them, and it seems nice.

I was quite surprised, then, when I upgraded my Nextcloud to and my existing collectives no longer appear. I can see the files related to my existing collectives right there on disk on the server, but they’re not showing up in Nextcloud. What might the problem be?

I’m not seeing anything relevant in the logs, so far.


Did you try to deactivate Collectives, delete the collectives Directory in the apps folder and install it new from the store?

I also upgraded from 22.0 to 22.1 and had no problems with my collectives…

I hadn’t tried that - in my few years running NextCloud I haven’t had an issue that I needed to solve in that way.

I’ve now tried it out:

  • I disabled and removed the app.
  • I poked into the custom_apps directory and confirmed the collectives folder was no longer there (ie. it seems there was nothing for me to remove).
  • I re-enabled the app.

My collectives remain invisible, despite the files still living on disk in the collectives folder under the appdata_<something> folder.

Hey @cos,

I’m sorry to hear that your Collectives disappeared. In order to better understand the scope of your problem, could you check the following:

  • Do you still see the underlying Circles of your missing Collectives? Each Collective has a corresponding Circle (with the same name). You find your Circles listed in the Contacts app.
  • Do you see the folder for your Collectives mounted in your home directory (in the Collectives subfolder).

If you don’t see the Circles, then please run the following command and see whether it fixes your issue:

php occ circles:memberships --all

I discovered some Circles migration issues myself when upgrading to 22.1 and they got fixed by the command above.



  • I confirmed I couldn’t see any Circles listed in Contacts, no.
  • There was an empty Collectives folder in my Nextcloud homedir.

However, running occ circles:memberships --all did indeed fix the problem!

Many thanks for your help, @mejo and @Soko!

1 Like

thank you @mejo for the solution you provided, however it seems that there is a bug with latest nextcloud instance (22.1.0) as this script has to run, every time a new user logs in, in order for the collectives/circles that he/she is a member of to appear on the UI/dashboard.
I have a social login, through own custom OpenID connect client and all my users, are mapped to the “user” group. I have create a circle/collective and granted member access to users that belong to the “user” group. However, as I mentioned when a user successfully logins the collectives appear only after execution of the solution you provided!

I do not understand how I can replicate this issue.

This is my testing, based on your description:

  • Create a Nextcloud group (test_group)
  • Create a new Circle (test_circle)
  • add test_group to the test_circle
  • listing the members of test_circle
maxence@stealth:~/sites/nc221/nextcloud$ ./occ circles:members:list gEMf6uboAdY2sOSK9wZJTkFQn6pqTVZ
| Circle Id                       | Circle Name | Member Id                       | Single Id                       | Type   | Source          | Username   | Instance | Level  | Invited By |
| gEMf6uboAdY2sOSK9wZJTkFQn6pqTVZ | test_circle | ZKVarNaRnOrTahUXOk7cMONxy4jTbKq | 2izUZSjxM8jX1HxBissiTNl1O1MYrwQ | user   | Nextcloud User  | cult       |          | Owner  | occ        |
| gEMf6uboAdY2sOSK9wZJTkFQn6pqTVZ | test_circle | kC1A6SWmqajafceN1r9FEmaFzmNHpAr | M3icBxJm27CtOehZlErWWxvwusbi4hk | circle | Nextcloud Group | test_group |          | Member | occ        |
  • creating a new user (test_user)
  • adding the new user to test_group
  • listing memberships from test_user


Database not updated means that the memberships were correct before running the command.

The test have been done on NC22.1.1-RC1.
Please confirm this process fit your current issue, and if you can reproduce my tests without any problem ?