Multiple Warnings After Upgrading from 27 to 28

Hello, I was hoping assistance can be provided please with an issue I’m having. I have two standard Nextcloud installations, one as a test instance and the other my personal main production instance. Both configured the same way. I’ve upgraded from Nextcloud 27 to 28 on my test machine and getting all kinds of warnings. I manage to resolve some but unable to find a way to remove the remaining two. Please advise if there is something I’m missing. Thank you.

Check your Nextcloud log, as it it says below the warnings. The error count is from your log. Also, if you’ve recently resolved some errors, it’s just telling you the count since February 1, 2024 so it likely includes whatever errors you had before that. It’s not a huge concern unless it starts increasing. But, again, the details will be in your logs.

And the ‘.mjs’ check failure indicates that your system is unable to connect to itself for some reason (DNS is the most common reason I’ve seen). Again, some further details will be logged with the exception in your logs for that test.

in my case the warning concerning missing support for *.mjs could only be solved by editing the file in /etc/nginx/mime.types

there finding the line starting with

application/javascript js;

this i need to change to

application/javascript js mjs;

After a restart of nginx / the server this message has been gone.

Thank you for your input. With that error log warning, disabling the “LogReader” app has strangely removed that warning. My production server with version 27.1.6 has it enabled and I have that nice green check :).

With the JavaScript warning, I think I may know the reason. Thanks again for your help.

That’s probably because they’re related: the logreader app in v28 requires .mjs support to be functioning in order for it to work. That was not the case in v27. :slight_smile:

I know this post may be closed, but after updating NC 28.0.3 RC2 on my test instance, that java script support warning was removed and I’m getting the green check. Good stuff! Thanks.

I updated from 28.0.2 to 28.0.3 RC2, but the problem is still there.

I have tried increasing the opcache.interned_strings_buffer value to a larger value, such as 128, 256, etc. but I get an OPcache module error.

Running NGINX add ‘mjs’ to your mime.types like

application/javascript                js mjs;

@i7-13700K I’m running a standard NC instance with MariaDB and Apache. I didn’t configure my server with NGINX. Hopefully what TomHH posted has fixed your issue.

My server is configured with Apache + MariaDB.