MS365 can't Open file

Hi Specialists,
when I try to Open a docx- or xlsx-file from Nextcloud app, MS365 says “Can’t open file
Office can’t find this file. It may have
been moved, renamed, or deleted”. This happens since a few days. I haven’t got any clue, why.
Can anybody help? Thanks for any Tipp.
Bfn
Michael

Same issue with opening PDFs from NextCloud App with Adobe Reader app and opening KDBX files from NextCloud App with KeePass2Android app

Hello @sven_m @Silvernerd1

Have you already tried to first make the files available locally (mark as available offline) and then open them?

I’m not sure, but maybe this can help.

1 Like

Hello @SchBenedikt
That seems to have first worked for PDF and KDBX files for me. However, what now happens (not always, but often) is that I download a file and then the file size immediatly and suddenly changes to 0 Bytes and the file has actually not downloaded. I refresh the view and the 0 Bytes stay with no download happening/happened. After App restart, the file size of the file is normal again, but the file is not downloading and has not downloaded still. I try again and the file size is 0 Bytes again. I can not download the files it seems.

You could try it on another device to see if it doesn’t work there either.

Do you use any “special” services such as Cloudflare, etc.?

Otherwise you could also open an issue in Github.

guys… @sven_m @Silvernerd1 your inquiry is missing almost every needed information…

you’re even not giving out which NC-Version you run nor which Androidclient version you do run.

Plus I could imagine that you guys didn’t even search the forum. So maybe this whole thing has to do with the ANdroid NC-App version that you run. At least that’s what I suspect.

Have a look here

Hello @SchBenedikt

With the Linux desktop client the files synchronize normally. Cloudflare etc. I’m not using. The problem occured some days ago. Before that downloading files in the NextCloud app worked fine.

@JimmyKater the thread here WARNING Nextcloud Android client version 3.28.1 deletes user data Revert back to 3.28.0 (F-Droid) - #12 by Oclair mentions that a 0-Bytes problem will be fixed with the next version 3.28.2. I currently have 3.28.1, so I’ll wait. Thank you for that. I searched the forum before, maybe not good enough. That does not excuse your attitude though. This world is already negative enough, no need for that. You can say the same thing you said in a nice way.

ummm… sorry mate, I wasn’t unfriendly with you at all. It’ just that 99% of all of these kind of inquiries are just like yours: not giving out even basic infos about your installation and thus causing loss of time to everyone who’s willing to help.
Be honest: have you put thought into HOW someone from here could even help you with your problems?
I can’t answer that question for you. But if you would have done it should have been clear from the beginning that everyone would need at least basic information about your server and server-environment because there are dozens if not hundreds/thousands of ways to run nextcloud.
Maybe you haven’t been aware of the neccessity of giving out infos… but then again if you were crawling through the forum you could have noticed that some ppl got reminded to give out more infos while others put a real efford into gaining and giving out a whole lot of infos.

To put it into a nutshell: Open Source is about giving and taking. You give out infos about problematic systems and are taking more or less good solutions if you’re lucky enough. Refusing your side of the deal could be regarded as “I don’t care about your time, just help me and be quick” which is impolite at first place.

And be sure I tell you all of that in a pretty good mood, listening to good music with the sun being out. No time for bad mood with me.

apart from that we all don’t know if I got you on the right track by mentioning this link. As I said: I’m just suspecting your problem being connected with that. But it could be something different as well.

Hey, here is the Update. As hoped the new NextCloud app update solved the problem for me!