Move data folder/select drive

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 22.1.1
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.41-4ubuntu3.4
PHP version (eg, 7.4): 7.4

The issue you are facing:
I’ve mounted an NFS drive to ubuntu and wish to use it as the Nextcloud storage drive. How do I do this?

Thanks, I saw that but because it’s older wasn’t sure if it was still applicable.

This is a brand new install, so I may just delete it and start over. I followed this install guide.

At what point would I edit the .conf to change the datadirectory? Before running ‘sudo a2ensite’ ?

yes it is, I bet it will remain the same for ages…

I have no idea how it works with “plain” setup - I started with Docker and in my eyes this is the best way to go. If you are not familiar with Docker it’s little hard to start but it’s worth because of huge flexibility (e.g. I’m running 2 instances - one “production” and one to test/play). I’ll try to help you with some docs…

I would say this is the point where you configure the data directory:

Configure Nextcloud

Browse to the Nextcloud server in your browser, and update the configuration to match the database info you’ve used earlier.

at least official installation guide shows this dialog , accessible through [Storage & database] drop-down menu:

here you can change the data directory on fresh installation…

I made the change there and now I’m running into another issue. The install successfully installed files there, but now I get an Error-

I’ve tried updating /etc/fstab to no avail. Any ideas? /mnt/storage nfs defaults uid=www-data,gid=www-data,umask=007 0 0

Got it figured out. Had to do with permissions on the Synology NAS. Added a www-data user and group and gave them full control of the shared folder and that did it.

1 Like

fstab of your host system is (not really) relevant. what is important is how the system inside docker see the directory (start a shell in your docker container and do ls -al on the data dir). take a look here maybe it helps

as last resort the setting 'check_data_directory_permissions' => false, into config.php might be last rescue (but please only use it in case you understand why other ways don’t work)

Thanks! Didn’t realize it was set there in the GUI. I’ll reinstall and do that.