Mounting WebDAV via GPO

We are currently working on a Nextcloud Server in our Company, but now we are facing a problem which could destroy most of our ambitions with Nextcloud.

We would like to have a Webdav drive mounted via GPO . If we mount it like a normal Windows Share (for example: \server\shares\shared-folder\ ) via https://nextcloud-url.remote.php/webdav or https://nextcloud-url/remote.php/dav/files/username

The Network Drive is not showing up.

If i connect it via the “net use” command, it works perfectly.

Has anybody an idea what could be our problem?

Nextcloud version (eg, 20.0.5): 21.0.1
Operating system and version (eg, Ubuntu 20.04): Debian 10
Apache or nginx version (eg, Apache 2.4.25): latest
PHP version (eg, 7.4): 7.4

Hey there, hope you are doing well…

Are you using AD/LDAP integrated users with nextcloud?

The same user accounts that logged into windows are used in nextcloud?

Have a nice day mate.

Hey,

yes, we are using LDAPs authentification und the Users are the same that are logged in on the Windows PCs.

Good morning Paul, how are you?

So, is the nextcloud’s server a trusted host to the dns?

My guess here, is because you are trying to connect externally (https://nextcloud.your.domain) and windows it’s not allowing that to happen.

So you have two options here:

1) Do a rule into your FW or DNS server to resolve it internally;
2) Add the nextcloud server to your trusted hosts inside your DC.

If you already tried that, please attach the GPO you are trying to use.

All the best, have a nice day.

:smiley:

Hey Beltram,

at the moment, we are trying to mount the drive internally and the DNS name is also resolved.
GPO_Nextcloud_1

And here, you can see the Policy I am using.

Edit: The same result happens with the internal DNS/Computer name, which is resolved.