Mobile app says file is synced but it is not

I am using 28.0.4 via Nextcloud AIO docker. For a phone I use a Pixel 8 with Graphene OS and the NC client. Untill now it worked flawlessly.

This week I updated my Keepass DB on my PC. I opened it on my phone, but the entry was not there. Looking at the mobile NC client it says it was modified at the time I modified it on my PC. Whatever I do: I do not get my PC version synced to the phone. When I download it from the web it’s fine.

Tried: moving the file to a different location.
Deleting the NC client, using the official version from the Play store.
Deleting KeepassXC.
Copying the file from the browser on the phone and pasting it to the location in the NC client.

After the uninstalls (and re-install) I now get “open failed: ENOENT (no such file or directory)”. Also the file seems to switch from 0KB to it’s correct file when refreshing in the NC mobile client.

Even more bizarre: when I could still open the file on my phone but it was not updated I put in a “test” entry. That test entry showed up on my PC just fine! But the DB on my phone never showed any entries I put in on my PC.

Anyone have any idea what is going on here?

Update: this is probably the issue: