Missing Files after installation?!

I downloaded NextCloud 10.0.1 from the official website nextcloud.com as a ZIP file. Unpacked locally, uploaded, ran through the installation And it is up and running, but reports missing and corrupt files (So I guess this is a installation question)


  • core
      • core/doc/admin/_sources/configuration_files/collaborative_documents_configuration.txt
      • core/doc/admin/_static/img/note_pencil.svg
      • core/doc/admin/_static/img/warning.svg
      • core/doc/admin/_static/style.css
      • core/fonts/LICENSE.txt
      • core/vendor/jsTimezoneDetect/jstz.js
  • files
      • ajax/download.php
      • ajax/getstoragestats.php
      • ajax/list.php
  • files_external
      • 3rdparty/Dropbox/API.php
  • files_texteditor
      • js/vendor/ace/src-noconflict/mode-diff.js

I checked the unpacked ZIP and the files simply are not there, so I can’t just upload them (again). And what about the files with invalid checksum? Should I upload these again?

I can use calender, shared calender with a second user and I can upload/download files. Everything Syncs with my Android Phone and Laptop. Only thing I stumbled across not working is when I open an ODT and try to share it.

Please help?

The presentation is a bit confusion, the missing files refer to the app files which can be found in /path/to/nextcloud/apps/files. When I download the zip file from nextcloud.com, I see the files which are told to be missing.

For the invalid hash, be careful with FTP there are different transmission modes which might change their hash-values (there was a longer thread about this during summer).

1 Like

Ah! I went to /mypathfornextcloud//core/ajax to look for the files… /apps/files/… makes sense. They were indeed missing. Fixed that part :smile:

The invalid hash does not go away, transmitting FTP in “automatic” mode in FileZilla. What Mode should I choose?

Thanks for the quick assist

1 Like

Thank you, it worked. Don’t know how FileZilla has the crazy idea to upload in ASCII mode…

I still get an “Error while sharing: Error!” error when sharing an open ODT, the issue does not seem connected, as I guessed. Will open a new thread, if I am unable to solve that.