Mise en veille serveur Nextcloud

Bonjour Ă  tous

J’ai montĂ© un serveur Nextcloud sur un mini PC, tout fonctionne Ă  merveille.
J’ai fait en sorte de pouvoir y accĂ©der de l’extĂ©rieur de mon rĂ©seau local.

Par contre il arrive rĂ©guliĂšrement que lorsque je veux y accĂ©der en dehors de chez moi qu’il soit hors ligne.
Je suis obligĂ© de le redĂ©marrer en rentrant car soit il reste allumĂ© mais sans pouvoir y accĂ©der via l’interface Web (l’IP de ma machine ne rĂ©pond plus au ping) ou pire il est Ă©teint.

Je pense qu’il me faut paramĂ©trer l’empĂȘchement d’une mise en veille ou autre chose


Quelqu’un a une idĂ©e ?
Merci par avance

Version Nextcloud en cours 21.0.3

Bonjour

Tu ne prĂ©cises pas dans ton message sur quel OS est installĂ© ton NC mais au vu du diagnostic cela ressemble beaucoup Ă  du Window$ ! As-tu dĂ©sactivĂ© toutes les options d’économie d’énergie aussi bien au niveau de l’OS que du bios du mini PC en question ?
Par contre Ă  vĂ©rifier si quand la machne rĂ©pond plus au ping mais est toujours on si la machne a plantĂ©e ou si c’est juste l’économie d’énergie qui a coupĂ© le port rĂ©seau !

VincĂšn

Ah sorry ! Et merci de me répondre

Nextcloud est installĂ© sur un Ubuntu Server 20.04.2. C’est pour cela que je trouve ca mystĂ©rieux car dans Windows, il est facile de dĂ©sactiver les options de mise en veille !

A mon avis, peut ĂȘtre que la machine Linux a plantĂ© comme tu le suggĂšre ?

A la base, ce mini PC Ă©tait sous Windows 10 quand je l’ai achetĂ©.

Essaie ça pour ĂȘtre sĂ»r :
sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

La page debian recommande une autre façon de faire plus dans “l’état de lart” mais ça revient au mĂȘme :
https://wiki.debian.org/Suspend#Disable_suspend_and_hibernation

Bonjour bastien

Je viens d’appliquer la commande que tu m’as donnĂ©
Pas de message d’erreur

Sur le lien, il est mentionnĂ© que cette commande fonctionne sur Debian 10 et plus rĂ©cent, Ă  voir si c’est la mĂȘme sur Ubuntu Server
En rĂšgle gĂ©nĂ©rale, mon serveur se met hors ligne environ entre 24 et 48h, je vais contrĂŽler ça et je reviens sur le forum dans quelque temps pour dire ce qu’il en est :slight_smile:

Ce qui fonctionne sur debian fonctionne sur Ubuntu. Ubuntu est basĂ© sur Debian et la doc debian est lune des meilleurs docs que j’ai pu voir.
Je te laisse faire un tour sur leur site, ils ont mĂȘme des doc de rĂ©fĂ©rence en français de quand mĂȘme quelques centaines de pages (Y a une version PDF). Par exemple, le manuel de rĂ©fĂ©rence de l’administrateur : https://www.debian.org/doc/manuals/debian-handbook/

Ubuntu 20 est basĂ© sur debian bullseye (11). La commande que j’ai donnĂ© fonctionne sur debian 8-9-10-11-
 C lautre solution (en modifiant le fichier nosuspend.conf) qui ne fonctionne que sur debian 10-11-
 Dans les deux cas c’est bon.

J’espùre que ça va marcher mais si ça marche pas c’est que le problùme est ailleurs :blush:

Joie de courte durée :roll_eyes:
Mon serveur s’est Ă©teint tout seul. Au bout d’un peu moins de 48h

Ce qui, je pense enlĂšve la thĂ©orie de l’économie d’énergie !

Une autre idée ? Merci

Up !
J’ai toujours le mĂȘme problĂšme
 Pour l’instant toujours pas de solution, si une ou plusieurs personnes peuvent m’aider.