Migrating from ownCloud gives error that downgrades not supported


I have an ownCloud instance running I’m trying to upgrade/migrate it to Nextcloud.

I’m trying both the manual and automated methods here:

With the automated method, it tells me:

Current version is 9.1.6.
Migration to Nextcloud 10.0.6 available.
Following file will be downloaded automatically: https://download.nextcloud.com/server/releases/nextcloud-10.0.6.zip

But then below in the extraction process it says:

Downloaded version is lower than installed version

Which… is wrong.

If I try the manual approach, I get essentially the same error message from both the GUI and the CLI tool:

Downgrading is not supported and is likely to cause unpredictable issues (from to

Which again is… wrong. I don’t know what has to do with anything.

Any idea what the issue is here? I’m at a loss for what it’s complaining about.

According to line 40 here:

there is an possible upgrade path from ownCloud 9.1 to Nextcloud 11.0.8

So I would do a manual upgrade to Nextcloud 11.0.8 strictly following the documentation for manual upgrades:

Thanks, but despite that file it’s still blocking an update to version 11:

$ php occ upgrade
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
Set log level to debug
Exception: Updates between multiple major versions and downgrades are unsupported.
Update failed
Maintenance mode is kept active
Reset log level

Hm. Sorry.

Then do manual update with version 10.0.6 and before running sudo -u www-data php occ upgrade change line 28 in version.php from
OC_Version = array(9, 1, 6, 1);
OC_Version = array(9, 1, 6, 3);

I hope that works then. Don‘t forget a backup before the upgrade!

Yeah, manual updates weren’t working, either. I also tried upgrading OC in place to the latest version (which worked), then cross-grading from there to Nextcloud from there. That failed the same way.

Searching around the forums it seems this is an extremely common problem, so I eventually gave up and just did a fresh reinstall. Basically the OC migration tool appears to be broken, period. :frowning:

I hope people on larger installs than my 2-user almost-all-files system can find some other workaround. I couldn’t.