Microsoft Edge Web Interface Animations are slow, Google Chrome working perfectly

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 27.0.1
Operating system and version (eg, Ubuntu 20.04): TrueNAS Core 13.0-U5.2
Apache or nginx version (eg, Apache 2.4.25): Caddy 2.6.4
PHP version (eg, 7.4): PHP 8.1.20

The issue you are facing:
Performance with the web interface is abysmal in Microsoft Edge. The Web interface loads fine (page loads in seconds) but all animations have frame lag and are slow to respond by half a second. It runs perfectly fine in Chrome.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Install Nextcloud in TrueNAS Core with this repo: GitHub - danb35/freenas-iocage-nextcloud: Script to create an iocage jail on FreeNAS for the latest Nextcloud 25 release, including Caddy, MariaDB or PostgreSQL, and Let's Encrypt
    1a. This does set up redis caching. I have confirmed it is running. I get no performance warnings in the Nextcloud administration summary page.
  2. Attempt to use the Web interface in Microsoft Edge. Make sure all extensions are disabled.

The output of your Nextcloud log in Admin > Logging:

(empty logfile)

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'passwordsalt' => '[...]',
  'secret' => '[...]',
  'trusted_domains' => 
  array (
    0 => 'localhost',
    1 => '[public domain with an A record pointin to a LAN IP]',
    2 => '[LAN IP]',
  'datadirectory' => '/mnt/files',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://[public domain]/',
  'dbname' => '[...]',
  'dbhost' => 'localhost:/var/run/mysql/mysql.sock',
  'dbport' => '',
  'dbtableprefix' => '[...]',
  'mysql.utf8mb4' => true,
  'dbuser' => '[...]',
  'dbpassword' => '[...]',
  'installed' => true,
  'instanceid' => '[...]',
  'logtimezone' => 'America/New_York',
  'default_phone_region' => 'US',
  'log_type' => 'file',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'loglevel' => '2',
  'logdateformat' => 'F d, Y H:i:s',
  'logrotate_size' => '104847600',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'overwritehost' => '[public domain]',
  'overwriteprotocol' => 'https',
  'htaccess.RewriteBase' => '/',
  'mail_smtpmode' => 'smtp',
  'mail_smtphost' => '[...]',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => '[...]',
  'mail_domain' => '[...]',
  'mail_smtpport' => '[...]',
  'mail_smtpauth' => [...],
  'mail_smtpname' => '[...]',
  'mail_smtppassword' => '[...]',
  'twofactor_enforced' => 'false',
  'twofactor_enforced_groups' => 
  array (
    0 => 'admin',
  'twofactor_enforced_excluded_groups' => 
  array (
  'app_install_overwrite' => 
  array (
    0 => 'files_3d',

The output of your Apache/nginx/system log in /var/log/____:

{"level":"info","ts":1690226707.6886506,"msg":"using provided configuration","config_file":"/usr/local/www/Caddyfile","config_adapter":"caddyfile"}
{"level":"info","ts":1690226707.6937878,"logger":"admin","msg":"admin endpoint started","address":"localhost:2019","enforce_origin":false,"origins":["//localhost:2019","//[::1]:2019","//"]}
{"level":"info","ts":1690226707.6940827,"logger":"tls.cache.maintenance","msg":"started background certificate maintenance","cache":"0xc00046ea10"}
{"level":"info","ts":1690226707.6941197,"logger":"http","msg":"server is listening only on the HTTPS port but has no TLS connection policies; adding one to enable TLS","server_name":"srv0","https_port":443}
{"level":"info","ts":1690226707.6941931,"logger":"http","msg":"enabling automatic HTTP->HTTPS redirects","server_name":"srv0"}
{"level":"info","ts":1690226707.695123,"logger":"http","msg":"enabling HTTP/3 listener","addr":":443"}
{"level":"info","ts":1690226707.6951609,"logger":"tls","msg":"cleaning storage unit","description":"FileStorage:/var/db/caddy/data/caddy"}
{"level":"info","ts":1690226707.6953063,"logger":"http.log","msg":"server running","name":"srv0","protocols":["h1","h2","h3"]}
{"level":"info","ts":1690226707.6953843,"logger":"http.log","msg":"server running","name":"remaining_auto_https_redirects","protocols":["h1","h2","h3"]}
{"level":"info","ts":1690226707.695411,"logger":"http","msg":"enabling automatic TLS certificate management","domains":["[public domain]"]}
{"level":"info","ts":1690226707.695958,"logger":"tls","msg":"finished cleaning storage units"}
{"level":"info","ts":1690226707.69683,"msg":"autosaved config (load with --resume flag)","file":"/var/db/caddy/config/caddy/autosave.json"}
{"level":"info","ts":1690226707.6968563,"msg":"serving initial configuration"}
Successfully started Caddy (pid=50154) - Caddy is running in the background

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

(empty log)

Profiling in Microsoft Edge shows a lot of dropped frames:

Never thought this could happen. Edge was updated already, but restarting Edge fully fixed this. :confused: