Memory caching and other config items not being recognised

I have a small hosted VPS running Debian 12 Bookworm. I have been running a nextcloud installation on the server without problems. Managed to get all the config warnings cleared up when I set it up.

Have added a second installation on a separate domain. The sites are hosted with Apache. I have checked the config.php files for the two instances, and apart from the specifics like data directory, URL, etc, they are identical. Specifically the memcache settings are identical, and there is a phone region:

 'memcache.local' => '\\OC\\Memcache\\APCu',
  'filelocking.enabled' => true,
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => 'localhost',
    'port' => 6379,
    'timeout' => 0,
  ),
  'default_phone_region' => 'ZA',

On the new instance, I am still getting these 3 warnings:
The database is used for transactional file locking.
No memory cache has been configured.
Your installation has no default phone region set.

Any clues. Sorry for sketchy configs and logs. If I need to add any such details to help with analysis, let me know what might help. Thanks

  • Check your Nextcloud Server logs for clues
  • Please run occ config:list system from both systems to make sure things are parsed accurately rather than just looking at the raw config.php.

If still stuck, please post the output from the above command.

Thanks. I ran the occ command as suggested and compared the output. I ran it through a text comparison website. Here’s the relevant text which is the same in both output files:

         "memcache.local": "\\OC\\Memcache\\APCu",
        "filelocking.enabled": true,
        "memcache.locking": "\\OC\\Memcache\\Redis",
        "redis": {
            "host": "***REMOVED SENSITIVE VALUE***",
            "port": 6379,
            "timeout": 0
        },
        "default_phone_region": "ZA",

Regarding logs, the nextcloud.log file that is created under Data is empty. Any other logs I should check?

I’ve also noticed that the directive

‘defaultapp’ => ‘files’,

is also not working given that on login I am still taken to the Dashboard.

Likewise

‘skeletondirectory’ => ‘’,

  • I tested by creating a new account and it was prepopulated with the usual test files.

Of interest, the email settings that are populated into the config.php file when entered in “Basic settings” on the site are working, so to speak - that settings page does still reflect them correctly.

In further news. I started again from scratch with the installation. The same thing is happening. I have not tried adding the memcache directives, but I tried with the phone region and the default app directives and the phone region error persists while the default app on login is still the dashboard.

HELP!!

I checked my system again today. All of a sudden, with no amendments by me, the phone code and the defaultapp directives have started working. The memcache errors are still showing.

I could imagine that there are some hidden control characters in the configuration file. Maybe it helps to open the file in another text editor.

1 Like

Okay I forgot that to test after my restart I only added the phone code and default app setting… so let me add the memcache stuff now.

Gave added the memcache directives. These were copied and pasted from the other site hosted on the same server for which they are working without issue. So there is no syntax problem. I also checked with occ config:list and the directives do show there. But the errors persist. Perhaps there is some other caching thing going on somewhere?

At the same time I re-added the blank skeleton directory directive and tested this by creating a new user. It is also being ignored, as the new user was given all the test files.

Rebooted and that seems to have fixed it. ??? (Am I suddenly running Windoze?)