Memories and Firefox

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 25.0.10
Operating system and version (eg, Ubuntu 20.04): raspbian
Apache or nginx version (eg, Apache 2.4.25): Apache2 2.4.56
PHP version (eg, 7.4): 7.4.33

The issue you are facing:
When I try to watch a video larger than 64 MB with Memories (V 5.4.1) and Firefox (any), I get “The media could not be loaded, either because the server or network failed or because the format is not supported.”. This happens only with the combination Memories / Firefox. Other browsers (tried Chrome and Falkon) play those videos fine, also if I open the video in Nextcloud via files or photos. No errors reported in any log. Video < 64 MB will play just fine. Tried on different client-computers.

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

  1. Open a video larger than 64 MB with Memories and Firefox
  2. Open the same video with Memories and another browser
  3. Open the same Video in Nextcloud with files or photos

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'XXXX',
  'passwordsalt' => 'xxxxxxxxx',
  'secret' => 'xxxxxxxxxxxxxxxxxxxxx',
  'trusted_domains' => 
  array (
    0 => '',
    1 => 'nextcloud.another.lan',
  'datadirectory' => '/mnt/elements/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://nextcloud.home.lan',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => 'xxxxxx',
  'installed' => true,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'default_phone_region' => 'DE',
  'mail_from_address' => 'me',
  'mail_smtpmode' => 'sendmail',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'nextcloud.home.lan',
  'mail_smtpsecure' => 'ssl',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'mailserver',
  'mail_smtpport' => '465',
  'mail_smtpname' => 'me@mailserver',
  'mail_smtppassword' => 'xxxxxx',
  'app_install_overwrite' => 
  array (
    0 => 'social',
    1 => 'files_external_gdrive',
  'filesystem_check_changes' => 1,
  'memories.exiftool' => '/var/www/html/nextcloud/apps/memories/exiftool-bin/exiftool-aarch64-glibc',
  'memories.vod.path' => '/var/www/html/nextcloud/apps/memories/exiftool-bin/go-vod-aarch64',
  'memories.vod.ffmpeg' => '/usr/bin/ffmpeg',
  'memories.vod.ffprobe' => '/usr/bin/ffprobe',
  'enabledPreviewProviders' => 
  array (
    0 => 'OC\\Preview\\Movie',
    1 => 'OC\\Preview\\Image',
  'memories.gis_type' => 1,

Does your browser console show anything interesting?

Might also be worth checking under the browser console Network tab to find out if there are any interesting network transactions at the time of the behavior.

In Network I only see “Media”, which loads only 64 MB.
The error console give me not much. One line says:

PsVideo: Direct video stream could not be opened. memories-main.js:2:1708964

The other :

Medien-Ressource https://nextcloud.vpn.lan/index.php/apps/memories/api/stream/1393805 konnte nicht dekodiert werden, Fehler: Error Code: NS_ERROR_DOM_MEDIA_METADATA_ERR (0x806e0006) Details: static MP4Metadata::ResultAndByteBuffer mozilla::MP4Metadata::Metadata(mozilla::ByteStream *): Cannot parse metadata

(Sorry, german translation active).

The other stuff seems not to be related (a load of “jQuery is deprecated…” etc.

I only see one issue with a similar output and it’s been fixed.

Might be worth a bug report.

I had a similar problem until I configured transcoding in the Memories application. However, after configuration, the situation is such that when playing a video in “Direct” quality in the Firefox browser, only 30 seconds of the video are played. This does not happen in other browsers. This problem also does not occur in any browser, including Firefox, when I play a video in the Files application in Nextcloud.