Meaningless message: 0 second(s) left, 0B of 109 GB, file 0 of 3824

Nextcloud 17.0.1, Nextcloud desktop client 2.3, Ubuntu 18.04.3.

I am successfully able to access and manage my Nextcloud server via the web browser. My Nexcloud server is on a device with 1TB of capacity.

I have 650 GB of data to upload from a local drive to my Nextcloud server.

I have been struggling with this since June (!) - five months - to get this to work.

Using the versions 2.5 and the current 2.6 of the desktop client never worked for me. The only one I found that worked is the version 2.3.

Using the version 2.3 of the desktop client, I have successfully uploaded 540 GB. Now I have only 109 GB remaining to upload.

Now, when I use the desktop client to upload the remaining 109 GB, it runs through checking all the directories on the local hard drive to see what remains to be uploaded, and then when that is done, instead of starting the uploading, it gives me this odd message: “0 second(s) left, 0 B of 109 GB, file 0 of 3824.” And it remains stuck like that forever.

Here are my questions:

  1. What on earth does that message mean? It makes no sense to me. (I am not a technical person.) It conveys no useful meaning to me.

  2. Why would the desktop client suddenly start giving this message after successfully uploading 540 GB with no problem? What is suddenly different?

  3. How do I go about figuring out what the problem is?

  4. How do I fix this?

Thank you in advance for any help.