Max File Size Upload Error

In ver 14.x, I have increased the file upload size option to 2 GB. I still get errors if the file size is > ~500 MB.

I’ve seen bug reports on this but would think that would not be the problem at this point in time, expecially given that the option is present to allow for larger files.

This happens both with uploads using the web interface as well as the Linux app. I kludged around the problem by slicing and dicing but that’s not a good, long-term solution.



NC is a web application, so, you need to update corresponding settings on the web server as well.

In my case, I use lighttpd, so I update the following lines/in files

server.max-request-size =

in file /etc/lighttpd/lighttpd.conf

upload_max_filesize =

in file /etc/php/7.0/cgi/php.ini

post_max_size =

in file /etc/php/7.0/cgi/php.ini

These is just for reference because different people have different hardware/OS/webserver component/version/… i.e. you may not find the said file on your computer, but it should not be difficult to google one that fit you.

Thanks, Vvong, for the suggestion. But modifying php.ini, the file of import on my server, did not fix the problem. In my case, I can split files and live with the issue. Kludgy but effective.