Matterbridge - no success connecting other services to Talk

Hello,
has anyone successfully connected an external chat service to a Talk chat using Matterbridge?

I tried bridging another Talk chat on another Nextcloud instance and an XMPP multi user chat room. Didn’t work.

I don’t get any error message in the Talk UI. It looks like everything is set up correctly. But no messages are transmitted to or from the bridged service.

When I connect an XMPP MUC I don’t see any attempt to connect to the XMPP server in the log of the XMPP server. So I assume the bridge is simply not active/working.

When I check the Nextcloud log I see two errors:

First, Matterbridge is trying to access a log file in /tmp. Complaining that file doesn’t exist or cannot be accessed. Weird. No application should have trouble creating files in /tmp.

Second, everytime I go to the Talk app with Matterbridge enabled, there is an error that a password isn’t valid because it must contain at least one upper case and one lower case character. Ugh… what password? My user password meets these conditions. So it must be something else. I’m clueless. -> Could be an app token (2FA), they usually don’t meet theses conditions.

System:

Two Nextcloud 20 installations
Talk and Matterbridge installed from app store
XMPP server is Prosody with working MUCs

Any idea what might be wrong with Mattermost?

Regards,
Steffen

Edit: Created the /tmp file manually with permissions for the webserver/php user. That error is gone.
Now I get… “Could not find resource core/js/files/client.js to load” in the log. Yep, that file doesn’t exist (seems to be a known bug in server/core).

1 Like

I’ve tried connecting to IRC on freenode, but that doesn’t seem to work either. I can connect quite happily with Hexchat and other clients, but all I get with the nextcloud matterbridge connection is:

time=“2020-10-25T10:10:21Z” level=info msg=“Running version 1.18.3 8b26e42a” prefix=main
time=“2020-10-25T10:10:21Z” level=fatal msg=“Failed to parse the configuration: While parsing config: (5, 2): The following key was defined twice: irc.0.NickServNick” prefix=config

The ‘Bridge with other services’ section in settings also keeps going from ‘Enabled (Running)’ to ‘Enabled (Not Running)’.

Either I’m doing something wrong, or it just plain doesn’t work, and there’s no explanation that I’ve seen so far with my brief search as to how to actually initiate the connection of if it should automatically connect as soon as you enter your connection details.

Same here, freenode it not working and telegram. if i hit “safe” it will be not safed.

Did you find a solution?

Are you talking about me? If so, no. I have (temporarily) given up.

1 Like

Update: It works now. :slight_smile:
Nextcloud 21.0.2
Talk 11.2.2
Talk Matterbridge 1.22.3

I have disabled the app ‘Password policy’ because it was causing the error ‘Password needs to contain at least one lower and one upper case character’.

I could establish a bridge to an XMPP multi user chat room now. :ballot_box_with_check: