Matomo does not track

Hi, I have installed “Piwik/Matomo Tracking” and I have installed Matomo also. both seems working but MAtomo does not track anything.
I found out the reason but i do not know how to solve. The debugger shows me the errors:

Content Security Policy: Die Einstellungen der Seite haben das Laden einer Ressource auf self blockiert (“script-src”). Source: (function (NAVIGATOR, OBJECT) {

_ OBJ… additional:1_

Content Security Policy: Die Einstellungen der Seite haben das Laden einer Ressource auf self blockiert (“script-src”). Source: (function (DOCUMENT, dispatchEvent, CUST… additional:1

JQMIGRATE: Migrate is installed, version 1.4.0 core.js:7:542

Laden fehlgeschlagen für das mit der Quelle “https://xxxx.xxxxxxxx.eupiwik.js/”. additional:1
Content Security Policy: Die Einstellungen der Seite haben das Laden einer Ressource auf https://piwik.sonavox.eupiwik.js/ blockiert (“script-src”).

Does anybody know how to allow “script-src” - I guess using htaccess in the right way?

thanks in advanced

element can be used to configure a policy, for example:

< meta http-equiv="Content-Security-Policy" content="default-src 'self'; img-src https://*; child-src 'none';">

Usually, csp is configure to accept content from himself

Content-Security-Policy: default-src 'self'; upgrade-insecure-requests; referrer no-referrer

If data come from outside domain:
Content-Security-Policy: default-src https://confidentiel.example.net

For more infos:
https://www.owasp.org/index.php/Content_Security_Policy_Cheat_Sheet

Hi all, i have the same problem: no tracking at all in Matomo: everything is perfectly configured.
Does this Matomo app already worked ??

Had that problem with Matomo-App 0.5 too…
Deinstalled Matomo app. Deleted the Folder in the App-Directory rebooted nextcloud and installed the app again.

Now it works again:
grafik

It is in fact working: in our instance there is a delay between the use of nextcloud and the stats beeing populated in Matomo (both on the same server).