Mass user import app/script

Hey guys !

My last thread was about sending mail to adressbook from contact app and what i want wasnt possible.

Now I’ve another question for you.
I saw few topic about that but i would like to know if you have a new solution.

So, i would like import 1600 ~user in nextcloud, i wont to create an account for every people.
Did you know if an app can do that or if a script exist ?

I have a .csv with display name and mail of people ready to import but i dont know how to proceed…

Thank you for your help already.


I think you haven’t tried to use the search function of this forum, have you?


Not with this key word its true.

But yes i tried.

Thank you

Maybe this script is a solution for you?

Hey Shen,

Thank you for your answer. This tools is exactly what i needed.
Unfortunately it doesnt work with self-signed cert.

Dexter work on it I think.


I git this error, when I execute this file:

Traceback (most recent call last):
File “”, line 462, in
File “requests/”, line 107, in post
File “requests/”, line 53, in request
File “requests/”, line 466, in request
File “requests/”, line 400, in prepare_request
File “requests/”, line 297, in prepare
File “requests/”, line 490, in prepare_auth
File “requests/”, line 51, in call
File “requests/”, line 31, in _basic_auth_str
UnicodeEncodeError: ‘latin-1’ codec can’t encode character ‘\u03c0’ in position 40: ordinal not in range(256)
[28941] Failed to execute script nc-userimporter

What I have to do?

nevermind, it was the password special character thing as well in the username. Sorry for that

Hello I tried to launch nc-userimporter on linux ubuntu 20.04 but i get this issue :
Traceback (most recent call last):
File “”, line 324, in
File “/usr/lib/python3.5/”, line 321, in decode
UnicodeDecodeError: ‘utf-8’ codec can’t decode byte 0xe9 in position 164: invalid continuation byte
[149957] Failed to execute script nc-userimporter