Markdown Editor in NC17 no longer working

After updating to NC17 the existing Markdown Editor App seems to be overruled by NC17 own Text App.

I already tried to deactivate Text-App. Unfortunately I am not able to get Markdown-App back to work.

As I think the Markdown-Editor is much better, I want to be able to use it again.

1 Like

looking into description of markdown app itself it told me that nc’s text app would need to be installed to work correctly.

i can’t provide any more help since you didn’t provide any info about your nc, your environment, your setup, no logs… nothing.


Tx for answering. I’m using/having installed

  • Nextcloud 17.0.3
  • Text 1.1.1
  • Markdown Editor 2.2.0
  • 1.1.3

Every time I try to edit a md file it is opened with Text. I’m not able to open it with Markdown Editor. At least I see no way to do so.

I would recommend to disable the Text app, which by defaults supports markdown documents now.

well ya, he did that and it didnt help. so i checked markdown app-site and it recommends having text enabled… (s.a.)

Ups, sorry I missed that.

Maybe a screenshot that compares when the app is enabled and when it is disabled will help.

I have the same problem as you.

I had the same issue. This helped me: Markdown app doesn't work after update to NC17

cd /path/to/nextcloud/apps
tar -xzf v17.0.0.tar.gz
mv files_texteditor-17.0.0 files_texteditor
find files_texteditor/ -type f -print0 | xargs -0 chmod 640
find files_texteditor/ -type d -print0 | xargs -0 chmod 750
chown -R <webserver user>:<webserver user> files_texteditor
rm v17.0.0.tar.gz

Create a File named and then click on it. The markdown Editor will open it :slight_smile: