Maps meldet, dass es Javascript braucht

Moin,

ich habe vor ein paar Tagen auf Nextcloud in der Docker Version gewechselt und habe hier schon wegen gewissen Dingen das Image anpassen müssen.

Nun ist mir aber aufgefallen, dass auch Maps noch Java fordert.

Diese Anwendung benötigt JavaScript zum ordnungsgemäßen Betrieb. Bitte <a href="https://www.enable-javascript.com/" target="_blank" rel="noreferrer noopener">aktiviere JavaScript</a> und lade die Seite neu. </div>
</div>

Muss ich das wirklich ins Image ziehen oder ginge das auch auf dem Hostsystem? Wenn im Image, welches Paket genau?

Freue mich über Rückmeldungen

LG

Es geht um Javascript und nicht um Java. Du musst in deiner Nextcloud nichts extra installieren. Javascript ist im Programmcode bereits enthalten. Aber vielleicht hast du im Browser Javascript deaktiviert. Wobei dann sollten wohl auch andere Teile deiner Nextcloud nicht funktionieren. Probiere evtl. mal einen anderen Browser.

1 Like

Ah ok.

Javascript habe ich aber bei meinem Browser aktiviert.

Die Meldung kommt dennoch, auch mit anderem Browser getestet, gleiches Problem.
Getestet habe ich es jetzt mit Firefox und Chrome. Das Problem bestand vor dem Wechsel zu Docker nicht, daher hatte ich das in einen Zusammenhang gebracht.

Meldung kommt leider immer noch. Habs nun mehrfach auch andere User testen lassen. Die haben alle die gleiche Meldung. Es betrifft aber nur den Part mit den Kontakten.

Laden der Kontakte fehlgeschlagen:


<div id="nojavascript">
<div>
Diese Anwendung benötigt JavaScript zum ordnungsgemäßen Betrieb. Bitte <a href="https://www.enable-javascript.com/" target="_blank" rel="noreferrer noopener">aktiviere JavaScript</a> und lade die Seite neu. </div>
</div>

Interner Serverfehler
Der Server konnte die Anfrage nicht fertig stellen.
Sollte dies erneut auftreten, sende bitte die nachfolgenden technischen Einzelheiten an deinen Server-Administrator.
Weitere Details können im Server-Protokoll gefunden werden.

Technische Details

Entfernte Adresse: 10.0.0.40

Die IP ist von meinem Reverse Proxy.

Hat keiner eine Idee?

ich habe das selbe Problem auch… verwende allerdings KEINEN Reverse-Proxy (selbiger wird ja hier gerne als “Buh-Mann” gebraucht. Also am Reverse-Proxy liegt es nicht. Bei mir wird die nie IP des Internet-GW’s angezeigt (fngiert auch als DNS)

Konntest Du das Problem lösen?
lG
Karl

Ja, aber nur mit dem Wechsel auf Nextcloud AIO. Das löste einfach das Problem.

bei mir nicht… ich verwende nämlich Nextcloud AIO (dockerized) lG Karl

Hier das gleiche Problem: Die Meldung, wonach Javascript erlaubt werden müsse, erscheint bildschirmfüllend für eine Zeit lang als Overlay über den Karten. Sie verschwindet nach einiger Zeit wieder. Ist aber ziemlich nervig, zumal JavaScript ja schon aktiviert war und ist.

Aber eigentlich auch egal, denn seit es die App Memories (Erinnerungen) gibt, welche neben Fotoalbum auch eine Kartendarstellung mitbringt, kann ich auf die Nextcloud-Maps gut verzichten. Zumal die Karten bei Memories die Position der Fotos anhand der Geo-Daten wesentlich exakter darstellt.

Die Nextcloud-Karten scheinen mir, ebenso wie Phots, doch seit längerer Zeit ziemlich lieblos zu verkommen. Vielleicht sollte man den Code von Memories standardmäßig als Ersatz für Photos und Maps einbinden. Denn auch Photos kann mit der Darstellung in Memories bei weitem nicht mithalten!