Manually Upgrading

I have been using Nextcloud in a Truenas Jail for quite some time without any problems that I could not fix myself. It’s always been a struggle updating in the Truenas Jail so I cringe whenever there is an update and usually put it off until I have time to resolve issues.

For a couple of weeks I have had problems uploading and downloading files using my Iphone outside of my home network so I attempted to try upgrading Nextcloud as the first step.

I had a warning saying PHP was out of date so I manually upgraded the Truenas Jail which did upgrade PHP to 8.0.30. I now cannot update Nextcloud nor can I access it. I get a message Exception: Updates between multiple major versions and downgrades are unsupported.

I am currently on Nextcloud
PHP 8.0.30
Truenas 13.0 Core

My question is which version in the changelog do I have to manually update to before I can update to 27.1.0 Do I need to update to each major version from 24 on upward, or can I skip any…

Thank you,


Yes, it is incremental. You will need to upgrade to each one.

Ok thank you for the quick response!

I hope this process will go smooth and not be to painful!


Were you able to upgrade from one version to the next version? If so, how did you do it?

I hope this isn’t too long winded… this might not be the best approach, but it worked for my situation.

I was unable to upgrade my Nextcloud instance on my Truenas Core server. I decided the best plan of action was to move all the files to a fresh install, moving away from Truenas jails and setting up a new machine. I setup another server (Dell R730XD) with Proxmox for the O.S. and created an Ubuntu Server VM. I installed Nextcloud as a docker container and manage the container with Portainer.

Once I had it successfully running and I was able to access from outside my network, I started the task of getting my files from the old instance to the new. I first tried just selecting all files and downloading them as a zip file. I uploaded the file and installed an app to unzip. It worked but for some reason most of the folders and files were “locked”. I was unable to modify or delete them. So I deleted this instance of Nextcloud and ran the docker setup again.

This time I used the Nextcloud desktop app and synced the old instance to a folder on my desktop, making sure I downloaded the files. Once that was complete I did the same thing with the new instance and copied all the files to a new folder on the desktop and synced that. That worked perfectly. I then deleted the folder on the desktop for the old instance and shutdown the Nextcloud jail on Truenas.

I have done one update so far and haven’t had any problems. I’m currently on version 27.1.4.


1 Like

Gotcha, thanks for the insight!