Mail notifications not sent out immeadiately for comments on files

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

System information

Nextcloud version (eg, 20.0.5):
Operating system and version (eg, Ubuntu 20.04): Archlinux on host with docker environment
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.52-1
PHP version (eg, 7.4): 8.0.19 via FPM

Problem description

The issue you are facing

The mail notifications of comments (with an @-mention) are not sent at all or way to late.

Is this the first time you’ve seen this error? (Y/N): Y, but I never tried it out.

Steps to replicate it:

I tested and played around with file comments and mentioned some users. I have two users A and B. File comments are configured to be notified both in stream as well as via email.

  1. I share a dummy file from either to the other.
  2. I login as sure A, user B is only logged in the Android app on my phone.
  3. I comment as user A and mention user B regarding the shared file.
  4. I check my mails from user B.

Additional comments and information

As uploading images here is broken ATM, I send you a link to the images here: Cloud des Tanzsportclubs im VfL Sindelfingen. The settings are captured from user Bs account. My understanding is that as soon as a comment by A mentioning B is sent to the NC core, a mail should be generated and send to B informing him of the comment. Additionally, a notification is generated in Bs activity timeline.
24h (or so) after the initial comment a new mail should be sent to B informing him of new notifications that are not yet processed.

I am getting the notification almost instantly (seen on the Android phone) and the mail after 24h. The main notification mail is not sent. I checked on my SMTP server, there is no mail transaction going on when I submit as A the comment. Other things are notified as expected and within mere seconds (until I see the message in the Postfix logs).

I tried to uncheck the settings, wait for saving, rechecked the settings , and waited again for saving. This was not helping.

Is this a bug? Can anyone else confirm this? Would this be an issue related to the core or the spreed/talk app (are comments part of talk, I am unsure if comments are realized by which app)?

Configuration and Logging

The output of your Nextcloud log in Admin > Logging:
There is nothing interesting logged. A warning related to the not yet completely installed antivirus but nothing related to the problem.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

See in the system report: Link:
Passwort: bUT8xQz8TRU3eXmLKBFQ

Configuration (config/config.php)
    "memcache.local": "\\OC\\Memcache\\APCu",
    "apps_paths": [
            "path": "\/srv\/data\/tsc-cloud\/cloud\/apps",
            "url": "\/apps",
            "writable": false
            "path": "\/srv\/data\/tsc-cloud\/cloud\/custom_apps",
            "url": "\/custom_apps",
            "writable": true
    "memcache.distributed": "\\OC\\Memcache\\Redis",
    "memcache.locking": "\\OC\\Memcache\\Redis",
    "redis": {
        "host": "***REMOVED SENSITIVE VALUE***",
        "password": "***REMOVED SENSITIVE VALUE***",
        "port": 6379
    "instanceid": "***REMOVED SENSITIVE VALUE***",
    "passwordsalt": "***REMOVED SENSITIVE VALUE***",
    "secret": "***REMOVED SENSITIVE VALUE***",
    "trusted_domains": [
    "datadirectory": "***REMOVED SENSITIVE VALUE***",
    "dbtype": "mysql",
    "version": "",
    "overwrite.cli.url": "https:\/\/",
    "dbname": "***REMOVED SENSITIVE VALUE***",
    "dbhost": "***REMOVED SENSITIVE VALUE***",
    "dbport": "",
    "dbtableprefix": "oc_",
    "mysql.utf8mb4": true,
    "dbuser": "***REMOVED SENSITIVE VALUE***",
    "dbpassword": "***REMOVED SENSITIVE VALUE***",
    "installed": true,
    "app_install_overwrite": [
    "maintenance": false,
    "mail_smtpmode": "smtp",
    "mail_smtpsecure": "tls",
    "mail_sendmailmode": "smtp",
    "mail_from_address": "***REMOVED SENSITIVE VALUE***",
    "mail_domain": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpauth": 1,
    "mail_smtpauthtype": "PLAIN",
    "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpport": "587",
    "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
    "mail_smtppassword": "***REMOVED SENSITIVE VALUE***"

The output of your Apache/nginx/system log in /var/log/____:

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

No error have been logged.