Mail App v1.5.1 Stucks on Loading Messages

I successfully upgraded to 20.0.1 (today). Everything was working fine including mail app. But later Mail app had an update to 1.5.1 after updating, mail stopped working.

Deleted the mail account
run “occ mail:clean-up”
disabled and removed app
reinstalled, added the account again
but i still get “Loading messages”.

Opened the database with pgAdmin
the account is added, but no new messages appear on the db.
Tried running “occ mail:account:sync 10 -f” (my current account id) and got:

[debug] account is up to date, skipping mailbox sync

In MailboxLockedException.php line 33:

331 is already being synced

After 3 hours i still get “331 is alerady being synced” so it doesn’t do anything…

Also tried on a test server i have, which was already on 20.0.1, mail app was fine, until i upgraded to 1.5.1. Same problem there.

Does your mail app works? Or is just me?

NC20.0.1, Docker on Unraid, Redis + Postgre13

PS. i have an @outlook.com account

EDIT1
Nextcloud log level to 0, doesn’t show anything for the mail app
On chromes network dev tab i see a tof on “sync” in the list and the preview is:

  1. {status: “fail”,…}

  2. data: {message: “401 is already being synced”, type: “OCA\Mail\Exception\MailboxLockedException”}

1. message: "401 is already being synced"
2. type: "OCA\Mail\Exception\MailboxLockedException"
  1. status: “fail”

Hi, i have the same problem and also the same setup like you with unraid :joy:

I hope this will get fixed soon.

“Nice” that i’m not alone. i was searching for hours to see what happens but cant find anything…

I’ve got the same issue on two installations—both also running Postgres, so maybe that’s a factor.

Should someone open an issue on github for this case?

Just did. Jump in, and provide any info if its needed!

1 Like