Mail App - Office 365 "Server Denied Authentication"

I have an Office 365 account with my university, and I was trying to connect the Mail app to my account to retrieve my mail. Upon entering the ‘correct’ settings manually, the mail app says “Creating account failed: Server denied authentication.” I have entered both a Gmail account and a Hotmail account and both connect fine.
Here are my settings:
IMAP server: Port: 993, SSL/TLS Login/pass: (I checked that these were correct) SMTP server: Port: 587, STARTTLS Login/pass: (same as above)
I have checked these settings with both Thunderbird and Evolution, both login and fetch mail just fine, and they’re the settings documented by Microsoft here.
Evolution says the supported protocols for authentication are the following
IMAP authentication: Password
SMTP authentication: Login

The entry in owncloud.log states the following:
{"reqId":"87IpsCMMkiNcieHIkZED","remoteAddr":"[Local IP, since this is on LAN]","app":"mail","message":"Creating account failed: Server denied authentication.","level":3,"time":"2016-07-12T00:02:28-04:00","method":"POST","url":"\/apps\/mail\/accounts","user":"[my user name]"}

Have you checked the Nextcloud log and the browser console for any errors?

This is the only entry relevant in the log - not very helpful.

I have opened an issue with the mail app github directly. I hope they don’t mind that I’m using Nextcloud.

1 Like

For what its worth, I haven’t had any luck setting up Office 365 either so it’s not just you.

My email isn’t with Office365 (it’s hosted on my HostGator account), and yet I’m having trouble with getting it to accept the credentials I use elsewhere, such as Thunderbird. Previously I had it worknig, although I think that was with v0.3, so I’m wondering if 0.4 introduced some kind of regression.

I believe 0.5.2 is shipped with Nextcloud 9.0.52, but maybe. The IMAP debug log is indeed strange for my case - there’s no explicit error, it’s just 4 commands that execute perfectly, then it just logs out and states that the “server denied authentication”.

Quite possibly. While I’m running NC 9.0.52 now though, the last time I tried the mail app was 8.2.2 + Mail app 0.4, so if there is a regression, it probably occurred somewhere between 0.3 and 0.4 and then lasted into 0.5.2

Maybe it’s a regression in the app. However, I’ve observed a similar bug with my university’s Microsoft mail server. The mail app failed connecting to that server out of a sudden when the IMAP server software was updated to a newer version. Hence, there might also be a change on the IMAP implementation of Office 365 that causes this bug.

1 Like

We don’t. The app works for both systems :wink:

there might also be a change on the IMAP implementation of Office 365 that causes this bug.

Possibly, however I’m not actually using office 365 and I seemed to be seeing something similar. I’ll have to try again with the current version though to confirm I still get the same issue. I can’t at the moment though as I’m having an nginx configuration issue that has my site down.