Mail App Email Loading Slow

Loading emails in the nextcloud mail app is very slow for me (10s+ on an average email), removing html and the encrypted elements from the vues makes it like 8 seconds faster but going with just the MessagePlainTextBody causes bad formatting.

Request Time (Never opened & Average length email):

  • thread - 94 ms
  • body - 2.69 s
  • html - 4.01 s
  • flags - 3.68 s

This is using googles SMTP and IMAP with their XOAuth as well, which should be a lot faster than this.

SMTP: smtp.gmail.com
IMAP: imap.gmail.com

1 Like

do you have a slow internet connection?

I’ve tested it on multiple connections, the current one being 400 down and 30 up.

what version of Mail do you use? at least loading the thread was recently improved.

Also how big are you oc_mail_* tables?

Hi there, I have the same issue. My oc_mail_* its not more 520kb.

When i try with roundcube with anonymous browser page, it´s 10x more faster.

I have the same issue on NC 20.0.10 Php 7.4 Apache/MariaDb.

This seems to be something to do with the priority mailbox. I can load emails fine if I just click on Inbox, but by default the priorty mailbox is show and that one never finishes “loading”

Anyway to disable priorty mailbox thing?

Hi Folks,

we have the same issue reported on a client site.
As you can see, i´ve attached our DB Tables of the Mail-Columns:
09.15.2021-12.27.46

Any Suggestions on this issue?
Thanks,
Dennis

1 Like

Hi,
i see basically the same. I’m the only user of my nextcloud instance and mail handling is in general really slow. The priority mailbox never stops loading. From time to time some message regarding “your messages are being indexed, this may take a while” flashes, but it never gets done. The same applies for the box “all mail entries” (i have 3 mail accounts connected, but it does not matter, if i have 2 or 3).
I’d like to second the question of ucarkamon: Any way to disable the priorty mailbox thing?
Thank you !

1 Like

Had the same slow loading problem or it was not loading at all…
After a:
occ maintenance:mimetype:update-db
the Mail app ist lightning fast…

fyi, that was the output:
Added mimetype “application/km” to database
Added mimetype “application/x-freemind” to database
Added mimetype “image/sgi” to database
Added mimetype “image/tga” to database
Added mimetype “application/vnd.xmind.workbook” to database