MacOS13.1 Ventura - NCClient 3.6.2 - Hang, does not respond, no sync

After a successful upgrade to MacOs Ventura, the NC client has been working flawlessly for two weeks.
Suddenly today, it has stopped working correctly. No sync is possible, NC client re-install does not help.


  • NC client starts normally.
  • Within a few seconds, CPU usage of NC client process reaches 100% and is unresponsive.
  • MacOs Task manager reports process is not responding.
  • The client is not accessible from the GUI for any other troubleshooting (mouse spinning wheel when hover).
  • Starting the client from the command line with the --logwindow flag does not allow to get any log reports, since the client becomes unresponssive immediately, and no logs are found when exiting.
  • Waiting does not help, client remains unresponsive and sollicitating 100% CPU.
  • No sync occurs, no contact is made with the NC server.
  • Attempts at removing and re-installing the latest client version, brings no improvement, and leads to the same symptoms.
  • Other clients from other devices are synching correctly to same NC server instance
  • NC Server instance is working perfectly, accepting and treating all requests as usual

Client version

Host system version
MacOs 13.0

Server version

Please let me know about any further information I may provide.
Attempting a MacOS upgrade from 13.0 to 13.0.1 in the mean time.


Upgrade to MacOs13.0.1 has been completed.
No change to issue. No sync. No NC client.


Same issue here. Activity monitor shows that nextcloud application is not responding and is using 100% cpu. Force-quitting and restarting the app and restarting the system have no effect.

FWIW, I just completed a fresh NC server install. When I linked my macOS desktop, it was able to download all the initial stock files that NC provides. When I attempted to add files of my own in the Finder, that’s when it stopped responding.

Edit: Pretty unsatisfying, but since I had just started from a new installation, I completely removed all of NC from my mac, including the various components in ~/Library. I re-installed NC desktop client 3.6.2 and re-linked my account. It synced correctly and so far it has let me add/remove files without issue. It is no longer hanging.


Thanks for your feedback about what seems to be a workaround (entirely removing all NC client related files before re-install of client).

I am not personnaly enclined to test this just yet as I have a rather complex client setup with a large number of different folders, and am concerned about losing files. I would rather wait for an NC approved analysis and fix to be provided.

For this reason I will not select your answer as “the” solution. Because there most likely is something wrong with NC client 3.6.2 on Mac. And will keep this ticket open.

But it does sound like a great workaround, when you have an easy sync setup configuration.
Thanks !

I was a premature in my response. While removing the client and reinstalling solved my issue of an immediate hang at launch, the macOS client is incredibly unstable. It hangs frequently, continuously consumes 100% cpu, etc. All my files were synced yesterday and today they are mostly not synced and some have a yellow ! next to them.

The iPhone client continues to work with no issues with my server setup



I’m seeing the same issue here on 2 different MAc’s, here’s some more info for people who might have the power to make things work :slight_smile:

I upgraded my Nextcloud server to 25 like 2 weeks ago, my Mac was up to date with Monterey and nextcloud client 3.6.2. I didn’t pay that much attention during those weeks up to yesterday when I realized my client was hanging and not responding at all and not syncing …

I started searching and trying to completely remove and reinstall 3.6.2, then 3.6.1, then 3.6.0 and then 3.4.1, same results. And I discovered how difficult it is to completely remove nextcloud from MacOS (I found some threads about that but what baffles me is that even after following those threads and really removing all files I could find in the depth of MacOS and then rebooting, as soon as I reinstall the client seems to connect no problem where I would like to have to for ex. reconnect to my server … so this means not every trace has bee removed …).

Being unsuccessful I decided to upgrade to Ventura in case something got corrupted in Monterey, I did again the uninstall-reinstall process for miscellaneous client versions, same results, my client is still hanging and not synchronizing. And one of my colleague still with Monterey has the same problem.

At this point I cannot figure out if the problem is with the server v25 or with the client … needless to say I was “happy” to find this thread, seems this problem is not with my install but more probably with the client itself or with v25. When the client crash, it happens so fast that I don’t think that the server could be the problem.


1 Like

Also for references, I found other threads about that problem:



I did some research on Github and found the following ticket: [Bug]: Desktop Client freezes in a 100% CPU load loop after server upgrade to 25 · Issue #5094 · nextcloud/desktop · GitHub concerning an OpenSuse client …

They do propose the following solution, adding 'bulkupload.enabled' => false, in the v25 server config.php and bingo, my client stopped hanging !!!

Would be interested to know if that does fix your issue !

Another fix is proposed on that thread: [Bug]: Desktop Client freezes in a 100% CPU load loop after server upgrade to 25 · Issue #5094 · nextcloud/desktop · GitHub , it does more or less the same by removing the bandwith limit on the client side … didn’t try it !



Thanks for sharing.

I have also set 'bulkupload.enabled' => false in my config.php, and can confirm this solved the issue on my end.

For now…
Still feels very uncomfortable as a solution… :confused:

Also, it appears that speed limits were automatically set in the client (I could now see them after disabling bulk upload, since the client was not freezing any more). I’m very certain they have been set by default by the new client, because I had specifically set them to no limit previously…

Bulk upload was very useful when syncing many small files, and greatly improves sync speed in this case.
I will try to remove the bulkupload.enable setting tomorrow (now that the network limits are removed in the client), and report here…

Also, another additional thread about this issue:

Thank you!

1 Like

Agreed, I’ll check also about the speed limit.

I’m on Fedora 37 Linux. I had the same issue. Setting the “Download Bandwidth” and “Upload Bandwidth” both to “No limit” solved the issue for Nextcloud Client 3.6.1.
I did not have to disable the bulkupload on my Nextcloud 25.0.1 server.
Maybe the title of this topic could be made more generic, as this does not seem to be a MacOS specific issue.

1 Like


I’m closing this now.
NC client has recieved a bugfix release (v3.6.4), and these issues are gone after upgrade.

Hi there,

Thank you for your contributions to the community!

I am still experiencing this problem with version 3.6.4git build 12826 on Mac OS 13.1

The workaround 'bulkupload.enabled' => false makes it possible to use the client

The problem is not yet solved, and it appears this locking feature is problematic to say the least especially when dealing with keepass password manager password file syncing between several devices.

Kind Regards,

1 Like

I am also having the same issue with Mac OS client, NC Server version 25.0.3 and NC Client 3.7.3. Changing ‘bulkupload.enabled’ => false in config.php removes the issue. Interested on a fix. ETA?

1 Like

I still have this issue with 3.7.3git (build 13809) on Ventura 13.2.1 (22D68)

I modified the config vile in var/www/nextcloud/config and added ‘bulkupload.enabled’ => false to the end of the file. After restarting my server, the client seems to work now again

1 Like