macOS Finder sync status icons and context menu missing

Nextcloud version (eg, 20.0.5): 28.0.3
Operating system and version (eg, Ubuntu 20.04): Linux 3.10.0
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.58
PHP version (eg, 7.4): 8.2.17
macOS version: 14.4.1
Nextcloud-client version: 3.12.3

The issue you are facing:
Since updating to macOS Sonoma (currently 14.4.1) three month ago, the Nextcloud-client hung up on system start so that I reinstalled it which solved the hang up issue. Nevertheless now all sync status icons and the context menu in the Finder app are missing. Synching as such is working fine. But I am missing the visual feedback for every file and for sharing of a file I now have to use the webUI because of the missing context menu.

If I configure the nextcloud client on another user on the same machine (MacBook Pro M1 2020), the icons and the context menu work just fine. So it seems to be related to my “daily use” user.

What I tried so far without any success:

  • Reinstalling Nextcloud client a second time (and deleting every nextcloud preference file I could find before reinstalling)
  • Defaulting Finder preferences
  • Checking permissions for Nextcloud client in system preferences (and comparing them to the other user on my machine, where the icons and the context menu work just fine)
  • Checking if Finder extensions for Nextcloud show up in system preferences and are activated
  • Restarting Finder after system start (this was a workaround for my issue some years ago it seems)

When I check my console app during launch of the Nextcloud client I see the following errors:

  • Plugin <id: 0x12da0ed40; core = <[u 6A82DF63-1A68-4D9D-A744-8CA3A69F1F85] [com.nextcloud.desktopclient.FinderSyncExt(1.0)],[d 64B68959-5BD5-4A7A-8624-A667F2BAB70E] [/Applications/]>, instance = [CF8A40C7-220E-43FE-82BF-61252767C8E2], state = 3, useCount = 0> must have pid! Extension request will fail
  • Unable to acquire process assertion in beginUsing: with plugin identifier: com.nextcloud.desktopclient.FinderSyncExt, killing plugin
  • PlugInKit error in beginUsing: with plugin identifier: com.nextcloud.desktopclient.FinderSyncExt, killing plugin
  • Prompting policy for hardened runtime; service: kTCCServiceAppleEvents requires entitlement but it is missing for accessing={TCCDProcess: identifier=com.nextcloud.desktopclient, pid=4342, auid=502, euid=502, binary_path=/Applications/}, requesting={TCCDProcess:, pid=811, auid=55, euid=55, binary_path=/System/Library/CoreServices/appleeventsd},

I’m a pro user of Macs for 20 years now and most of the time I am able to solve my issues with googling or nowadays even asking ChatGPT. But this time I need your help. I’m not quite sure, what those errors in the console should tell me, hence how I could fix them …

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Just starting the Nextcloud client and no sync status icons or context menu appear

Thanks in advance!

I just found old topics, either much older client, and/or different mac OS version. Once they mentioned there might be overlay icons from other apps that caused a conflict:

Other than that, I’d create an issue on the bug tracker.